aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.python.mk
diff options
context:
space:
mode:
authorThomas Gellekum <tg@FreeBSD.org>2001-03-01 12:17:41 +0000
committerThomas Gellekum <tg@FreeBSD.org>2001-03-01 12:17:41 +0000
commit80d3dac31c3678282ddc342252ff57003aaa85fe (patch)
tree1a472b29612d0af5b00ab6e0e4e1b014fecaef28 /Mk/bsd.python.mk
parenta17f7f39ac133b458dda0f8b123bdf885619d507 (diff)
downloadports-80d3dac31c3678282ddc342252ff57003aaa85fe.tar.gz
ports-80d3dac31c3678282ddc342252ff57003aaa85fe.zip
Notes
Diffstat (limited to 'Mk/bsd.python.mk')
-rw-r--r--Mk/bsd.python.mk17
1 files changed, 16 insertions, 1 deletions
diff --git a/Mk/bsd.python.mk b/Mk/bsd.python.mk
index 63f0a110e0c9..28eac650978e 100644
--- a/Mk/bsd.python.mk
+++ b/Mk/bsd.python.mk
@@ -90,6 +90,21 @@ PYTHON_REL= 200
PYTHON_SUFFIX= # empty, default version
PYTHON_WRKSRC= ${WRKDIR}/Python-2.0
+# Python-1.6
+# ${PYTHON_PORTSDIR} is not set because we don't support building
+# Python-1.6 from the ports anymore. People should use the
+# latest version in ${PORTSDIR}/lang/python. The definitions here
+# are for those who still have 1.6 as their default version.
+.elif ${PYTHON_VERSION} == "python1.6"
+PYDISTUTILS= ${PYTHON_LIBDIR}/site-packages/distutils/core.py:${PORTSDIR}/misc/py-distutils
+PYXML= ${PYTHON_SITELIBDIR}/xml/__init__.py:${PORTSDIR}/textproc/py-xml
+
+PYTHON_DISTFILE= Python-1.6.tar.gz
+PYTHON_PORTSDIR= # empty
+PYTHON_REL= 160
+PYTHON_SUFFIX= 16
+PYTHON_WRKSRC= ${WRKDIR}/Python-1.6
+
# Python-1.5
.elif ${PYTHON_VERSION} == "python1.5"
PYDISTUTILS= ${PYTHON_LIBDIR}/site-packages/distutils/core.py:${PORTSDIR}/misc/py-distutils
@@ -104,7 +119,7 @@ PYTHON_WRKSRC= ${WRKDIR}/Python-1.5.2
.else
.BEGIN:
@${ECHO} "Error: bad value for PYTHON_VERSION: ${PYTHON_VERSION}."
- @${ECHO} "Use one of python1.5 or python2.0 (default)."
+ @${ECHO} "Use one of python1.5, python1.6 or python2.0 (default)."
@${FALSE}
.endif