aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.qt.mk
diff options
context:
space:
mode:
authorDoug Barton <dougb@FreeBSD.org>2011-07-01 19:25:47 +0000
committerDoug Barton <dougb@FreeBSD.org>2011-07-01 19:25:47 +0000
commit3239a560ee9e5b2368120ebafc19f107dcb69754 (patch)
treed6b451aae5d42dcdea54b7721db2df6b4eb4ed0e /Mk/bsd.qt.mk
parenta78ddbceddab50487e7200c8f296bd386321bf6f (diff)
downloadports-3239a560ee9e5b2368120ebafc19f107dcb69754.tar.gz
ports-3239a560ee9e5b2368120ebafc19f107dcb69754.zip
Notes
Diffstat (limited to 'Mk/bsd.qt.mk')
-rw-r--r--Mk/bsd.qt.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/Mk/bsd.qt.mk b/Mk/bsd.qt.mk
index a23b2fa4aee5..384c772dbc12 100644
--- a/Mk/bsd.qt.mk
+++ b/Mk/bsd.qt.mk
@@ -112,7 +112,7 @@ QMAKEFLAGS+= QMAKE_CC="${CC}" QMAKE_CXX="${CXX}" \
#
# Translate `c++` to its real name and select the appropriate mkspec.
#
-QMAKE_BASE_COMPILER!= cc --version 2> /dev/null | awk 'NR == 1 { gsub(/[()]/, "", $2); print $2 }'
+QMAKE_BASE_COMPILER!= cc --version | head -1 | sed -E 's/.+\(([^)]+)\).+/\1/' | cut -d " " -f 1
.if ${QMAKE_BASE_COMPILER:L} == "gcc"
QMAKE_BASE_COMPILER= g++
.endif