aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.tcl.mk
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2013-02-06 15:25:57 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2013-02-06 15:25:57 +0000
commit7babc1bb95232dc09d5019b337df03038e8fd950 (patch)
tree8cbdc6f08204001571646680976f53bb040ddf9b /Mk/bsd.tcl.mk
parent84ac8e953561634e02f5855ef79a6f273fc34a07 (diff)
downloadports-7babc1bb95232dc09d5019b337df03038e8fd950.tar.gz
ports-7babc1bb95232dc09d5019b337df03038e8fd950.zip
Notes
Diffstat (limited to 'Mk/bsd.tcl.mk')
-rw-r--r--Mk/bsd.tcl.mk108
1 files changed, 10 insertions, 98 deletions
diff --git a/Mk/bsd.tcl.mk b/Mk/bsd.tcl.mk
index 8d046c5995b8..caec666ad0ba 100644
--- a/Mk/bsd.tcl.mk
+++ b/Mk/bsd.tcl.mk
@@ -38,13 +38,6 @@ Tcl_Include_MAINTAINER= mm@FreeBSD.org
# NOTE: INVALID_TCL_VER takes precedence
# <UNIQUENAME>_WITH_TCL_VER - User defined port specific variable to set Tcl version
##
-# USE_TCL_THREADS - If defined, Tcl a threaded version of tcl is required.
-# NOTE: support for threaded builds starts with version 84
-# USE_TCL_NO_THREADS - If defined, port may not use a threaded Tcl, even if requested via
-# USE_TCL_THREADS or WITH_TCL_THREADS
-# WITH_TCL_THREADS - User defined variable to use Tcl with threads
-# <UNIQUENAME>_WITH_TCL_THREADS - User defined port specific variable to require Tcl with threads
-##
# TCL_VER - Detected by bsd.tcl.mk. Contains the version number of Tcl to be used.
#
##
@@ -79,14 +72,6 @@ Tcl_Include_MAINTAINER= mm@FreeBSD.org
# <UNIQUENAME>_WITH_TK_VER - User defined port specific variable to set Tk version
# NOTE: overrides <UNIQUENAME>_WITH_TCL_VER.
##
-# USE_TK_THREADS - Tk has to obey tcl in threads. A threaded Tk requires
-# a threaded Tcl and a non-threaded Tcl requires a non-threaded Tk.
-# This variable defines USE_TCL_THREADS
-# USE_TK_NO_THREADS - If defined, port may not use a threaded Tk, even if requested via
-# USE_TK_THREADS or WITH_TK_THREADS. Defines USE_TCL_NO_THREADS
-# WITH_TK_THREADS - User defined variable to use Tk with threads
-# <UNIQUENAME>_WITH_TK_THREADS - User defined port specific variable to require Tk with threads
-###
# TCL_LIBDIR - Path where tcl libraries can be found
#
# TCL_INCLUDEDIR - Path where tcl C headers can be found
@@ -142,24 +127,6 @@ _TK_BUILD_DEPENDS= yes
. endif
.endif
-# Set WITH_TCL_THREADS or WITH_TK_THREADS if port-specific define
-. if defined(${UNIQUENAME:U:S,-,_,}_WITH_TCL_THREADS)
-WITH_TCL_THREADS= yes
-. endif
-. if defined(${UNIQUENAME:U:S,-,_,}_WITH_TK_THREADS)
-WITH_TK_THREADS= yes
-.endif
-
-# If a threaded Tcl or Tk is requested we require a threaded Tcl
-. if !defined(USE_TK_NO_THREADS) && !defined(USE_TCL_NO_THREADS)
-. if defined(USE_TCL_THREADS) || defined(USE_TK_THREADS)
-USE_TCL_THREADS= yes
-. endif
-. if defined(WITH_TK_THREADS)
-WITH_TCL_THREADS= ${WITH_TK_THREADS}
-. endif
-. endif
-
# Override the global WITH_TCL_VER or WITH_TK_VER with the
# port specific <UNIQUENAME>_WITH_TCL_VER or <UNIQUENAME>_WITH_TK_VER
. if defined(${UNIQUENAME:U:S,-,_,}_WITH_TCL_VER)
@@ -192,9 +159,7 @@ INVALID_TCL_VER:= ${INVALID_TK_VER}
_TCL_DEFAULT_VERSION= 85
_TCL_VERSIONS= 86 85 84 83
-_TCL_THREADS_VERSIONS= 86 85 84
_TCL_RANGE_VERSIONS= 86+ 85+ 84+ 83+
-_TCL_THREADS_RANGE_VERSIONS= 86+ 85+ 84+
# For specifying [85, 84, ..]+
_TCL_83P= 83 84 85 86
@@ -207,47 +172,6 @@ _TCL_86P= 86
USE_TCL= ${_TCL_DEFAULT_VERSION}
. endif
-# Support for obsolete 84-thread and 85-thread definitions
-. if ${USE_TCL} == "84-thread" || ${USE_TCL} == "85-thread"
-USE_TCL:= ${USE_TCL:S/-thread//}
-USE_TCL_THREADS= yes
-. endif
-
-# Ignore WITH_TCL_THREADS if USE_TCL is
-# not in _TCL_THREADS_VERSIONS or _TCL_RANGE_VERSIONS
-. if defined(WITH_TCL_THREADS)
-. for ver in ${_TCL_THREADS_VERSIONS} ${_TCL_RANGE_VERSIONS}
-. if ${USE_TCL} == "${ver}"
-USE_TCL_THREADS= yes
-. endif
-. endfor
-. endif
-
-# Check if a build with threads is required
-. if !defined(USE_TCL_NO_THREADS) && !defined(USE_TK_NO_THREADS) && !defined(BUILDING_TCL_THREADS) && !defined(BUILDING_TK_THREADS)
-. if defined(USE_TCL_THREADS)
-_TCL_THREADS_PORT= -thread
-_TCL_THREADS_SUFFIX= -threads
-
-# Threaded Tcl/Tk accepts only ranges starting with 84+
-# reset the range to 84+ if the value is lower
-. for ver in ${_TCL_RANGE_VERSIONS}
-. if ${USE_TCL} == "${ver}"
-_TCL_T_BAD_RANGE= yes
-. for tver in ${_TCL_THREADS_RANGE_VERSIONS}
-. if ${USE_TCL} == "${tver}"
-_TCL_T_BAD_RANGE= no
-. endif
-. endfor
-. endif
-. endfor
-. if defined(_TCL_T_BAD_RANGE) && ${_TCL_T_BAD_RANGE} == "yes"
-USE_TCL= 84+
-. endif
-
-. endif
-. endif
-
_TCL_VER= no
# Check if we have user-defined WITH_TCL_VER and if it matches
@@ -343,38 +267,26 @@ _FOUND= yes
. endif
. endfor
-. if ${_FOUND} == "yes" && defined(USE_TCL_THREADS)
-_FOUND= no
-_THREADED_NOT_FOUND= yes
-. for ver in ${_TCL_THREADS_VERSIONS}
-. if ${USE_TCL} == "${ver}" && ${_FOUND} == "no"
-_FOUND= yes
-. endif
-. endfor
-. endif
-
. if ${_FOUND} == "yes"
TCL_INCLUDEDIR= ${LOCALBASE}/include/tcl${TCL_VER}
-TCL_LIBDIR= ${LOCALBASE}/lib/tcl${TCL_VER}${_TCL_THREADS_SUFFIX}
-TCLSH= ${LOCALBASE}/bin/tclsh${TCL_VER}${_TCL_THREADS_SUFFIX}
+TCL_LIBDIR= ${LOCALBASE}/lib/tcl${TCL_VER}
+TCLSH= ${LOCALBASE}/bin/tclsh${TCL_VER}
# Add dependencies
. if !defined(_TK_ONLY)
. if !defined(_TCL_RUN_DEPENDS) && !defined(_TCL_BUILD_DEPENDS)
-LIB_DEPENDS+= tcl${USE_TCL}${_TCL_THREADS_SUFFIX}:${PORTSDIR}/lang/tcl${USE_TCL}${_TCL_THREADS_PORT}
+LIB_DEPENDS+= tcl${USE_TCL}:${PORTSDIR}/lang/tcl${USE_TCL}
. else
. if defined(_TCL_BUILD_DEPENDS)
-BUILD_DEPENDS+= tclsh${TCL_VER}${_TCL_THREADS_SUFFIX}:${PORTSDIR}/lang/tcl${USE_TCL}${_TCL_THREADS_PORT}
+BUILD_DEPENDS+= tclsh${TCL_VER}:${PORTSDIR}/lang/tcl${USE_TCL}
. endif
. if defined(_TCL_RUN_DEPENDS)
-RUN_DEPENDS+= tclsh${TCL_VER}${_TCL_THREADS_SUFFIX}:${PORTSDIR}/lang/tcl${USE_TCL}${_TCL_THREADS_PORT}
+RUN_DEPENDS+= tclsh${TCL_VER}:${PORTSDIR}/lang/tcl${USE_TCL}
. endif
. endif
. endif
-. elif defined(_THREADED_NOT_FOUND) && !defined(IGNORE)
-IGNORE= the defined version of Tcl/Tk does not support threads: ${USE_TCL}
. elif !defined(IGNORE)
IGNORE= unknown Tcl/Tk version specified: ${USE_TCL}
. endif
@@ -389,19 +301,19 @@ USE_TK:= ${USE_TCL}
TK_VER:= ${USE_TCL:S/8/8./}
. if !defined(_TK_RUN_DEPENDS) && !defined(_TK_BUILD_DEPENDS)
-LIB_DEPENDS+= tk${USE_TK}${_TCL_THREADS_SUFFIX}:${PORTSDIR}/x11-toolkits/tk${USE_TK}${_TCL_THREADS_PORT}
+LIB_DEPENDS+= tk${USE_TK}:${PORTSDIR}/x11-toolkits/tk${USE_TK}
. else
. if defined(_TK_BUILD_DEPENDS)
-BUILD_DEPENDS+= wish${TK_VER}${_TCL_THREADS_SUFFIX}:${PORTSDIR}/x11-toolkits/tk${USE_TK}${_TCL_THREADS_PORT}
+BUILD_DEPENDS+= wish${TK_VER}:${PORTSDIR}/x11-toolkits/tk${USE_TK}
. endif
. if defined(_TK_RUN_DEPENDS)
-RUN_DEPENDS+= wish${TK_VER}${_TCL_THREADS_SUFFIX}:${PORTSDIR}/x11-toolkits/tk${USE_TK}${_TCL_THREADS_PORT}
+RUN_DEPENDS+= wish${TK_VER}:${PORTSDIR}/x11-toolkits/tk${USE_TK}
. endif
. endif
TK_INCLUDEDIR= ${LOCALBASE}/include/tk${TK_VER}
-TK_LIBDIR= ${LOCALBASE}/lib/tk${TK_VER}${_TCL_THREADS_SUFFIX}
-WISH= ${LOCALBASE}/bin/wish${TK_VER}${_TCL_THREADS_SUFFIX}
+TK_LIBDIR= ${LOCALBASE}/lib/tk${TK_VER}
+WISH= ${LOCALBASE}/bin/wish${TK_VER}
. endif # defined(USE_TK)
. endif # defined(USE_TCL)