aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.tcl.mk
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2013-05-21 08:59:02 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2013-05-21 08:59:02 +0000
commite69c0f9b763a3fff8c9206ec996fb363e9e2109b (patch)
tree966cefb077f0d7565b211948b5f385a74ef90c40 /Mk/bsd.tcl.mk
parent3436f1afdc741797e2c75e20604e6dc8ae977d25 (diff)
Notes
Diffstat (limited to 'Mk/bsd.tcl.mk')
-rw-r--r--Mk/bsd.tcl.mk18
1 files changed, 9 insertions, 9 deletions
diff --git a/Mk/bsd.tcl.mk b/Mk/bsd.tcl.mk
index bfd43e47a438..a62a27fff2d9 100644
--- a/Mk/bsd.tcl.mk
+++ b/Mk/bsd.tcl.mk
@@ -13,7 +13,7 @@ Tcl_Include_MAINTAINER= mm@FreeBSD.org
# via the port or by the user via defined variable try to find the highest
# stable installed version.
# Available values: yes 86+ 85+ 84+ 85 84
-# NOTE: - default value 85 is used in case of USE_TCL=yes
+# NOTE: - default value 86 is used in case of USE_TCL=yes
#
# USE_TCL_BUILD - Add buildtime dependency on Tcl (tclsh).
# Available values: see USE_TCL
@@ -28,12 +28,12 @@ Tcl_Include_MAINTAINER= mm@FreeBSD.org
# a specific tclsh version may use this.
# The tclsh wrapper script installs into ${LOCALBASE}/bin/tclsh
# NOTE: - USE_TCL_WRAPPER and USE_TCL can be used together
-# - ports using the wrapper should support default Tcl (8.5)
+# - ports using the wrapper should support default Tcl (8.6)
##
# INVALID_TCL_VER - This variable contains a list of Tcl versions not supported by the port.
-# This setting is effective only when USE_TCL is set to a range (e.g. 84+)
+# This setting is effective only when USE_TCL is set to a range (e.g. 85+)
# WITH_TCL_VER - User defined global variable to set Tcl version
-# This variable is effective only if USE_TCL is set to a range (e.g. 84+)
+# This variable is effective only if USE_TCL is set to a range (e.g. 85+)
# and WITH_TCL_VER points inside that range.
# NOTE: INVALID_TCL_VER takes precedence
# <UNIQUENAME>_WITH_TCL_VER - User defined port specific variable to set Tcl version
@@ -46,7 +46,7 @@ Tcl_Include_MAINTAINER= mm@FreeBSD.org
# stable installed version.
# Avaliable values: yes 86+ 85+ 84+ 85 84
# NOTE: - overrides USE_TCL
-# - default value 85 is used in case of USE_TK=yes
+# - default value 86 is used in case of USE_TK=yes
#
# USE_TK_BUILD - Add buildtime dependency on Tk (wish).
# Available values: see USE_TK
@@ -61,12 +61,12 @@ Tcl_Include_MAINTAINER= mm@FreeBSD.org
# a specific wish version may use this.
# The wish wrapper script installs into ${LOCALBASE}/bin/wish
# NOTE: - USE_TK_WRAPPER and USE_TK can be used together.
-# - ports using the wrapper should support default Tk (8.5)
+# - ports using the wrapper should support default Tk (8.6)
##
# INVALID_TK_VER - This variable contains a list of Tk versions not supported by the port
-# This setting is effective only when USE_TK is set to a range (e.g. 84+)
+# This setting is effective only when USE_TK is set to a range (e.g. 85+)
# WITH_TK_VER - User defined global variable to set Tk version.
-# This variable is effective only if USE_TK is set to a range (e.g. 84+)
+# This variable is effective only if USE_TK is set to a range (e.g. 85+)
# and WITH_TK_VER points inside that range.
# NOTE: overrides WITH_TCL_VER.
# <UNIQUENAME>_WITH_TK_VER - User defined port specific variable to set Tk version
@@ -157,7 +157,7 @@ INVALID_TCL_VER:= ${INVALID_TK_VER}
#
. if defined(USE_TCL)
-_TCL_DEFAULT_VERSION= 85
+_TCL_DEFAULT_VERSION= 86
_TCL_VERSIONS= 86 85 84
_TCL_RANGE_VERSIONS= 86+ 85+ 84+