aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.xorg.mk
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2015-03-21 23:05:19 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2015-03-21 23:05:19 +0000
commita5da770e67afce95b829c38c5d5330fe69f7822c (patch)
treeb9556c9042a9d20d7c71f49869f39f95afc00052 /Mk/bsd.xorg.mk
parent51da733b698e7bbedaac4743f457352334401249 (diff)
downloadports-a5da770e67afce95b829c38c5d5330fe69f7822c.tar.gz
ports-a5da770e67afce95b829c38c5d5330fe69f7822c.zip
Notes
Diffstat (limited to 'Mk/bsd.xorg.mk')
-rw-r--r--Mk/bsd.xorg.mk10
1 files changed, 7 insertions, 3 deletions
diff --git a/Mk/bsd.xorg.mk b/Mk/bsd.xorg.mk
index f3f8ebc563e5..3aa18c3c60c0 100644
--- a/Mk/bsd.xorg.mk
+++ b/Mk/bsd.xorg.mk
@@ -70,12 +70,14 @@ USES+= libtool
. if ${XORG_CAT} == "font"
FONTNAME?= ${PORTNAME:C/.*-//g:S/type/Type/:S/ttf/TTF/:S/speedo/Speedo/}
-CONFIGURE_ARGS+= --with-fontrootdir=${PREFIX}/lib/X11/fonts
-CONFIGURE_ENV+= FONTROOTDIR=${PREFIX}/lib/X11/fonts
+CONFIGURE_ARGS+= --with-fontrootdir=${PREFIX}/share/fonts
+CONFIGURE_ENV+= FONTROOTDIR=${PREFIX}/share/fonts
. if !defined(NOFONT)
USES+= fonts
BUILD_DEPENDS+= mkfontdir:${PORTSDIR}/x11-fonts/mkfontdir \
bdftopcf:${PORTSDIR}/x11-fonts/bdftopcf
+PLIST_FILES+= "@comment ${FONTSDIR}/fonts.dir" \
+ "@comment ${FONTSDIR}/fonts.scale"
. endif
. endif
@@ -93,7 +95,9 @@ USES+= pathfix
DISTFILES?= xorg-server-${PORTVERSION}.tar.bz2
WRKSRC= ${WRKDIR}/xorg-server-${PORTVERSION}
USES+= pathfix
-CONFIGURE_ARGS+= --with-xkb-path=${LOCALBASE}/share/X11/xkb
+CONFIGURE_ARGS+= --with-xkb-path=${LOCALBASE}/share/X11/xkb \
+ --with-fontrootdir=${LOCALBASE}/share/fonts \
+ --with-default-font-path="catalogue:${LOCALBASE}/etc/X11/fontpath.d,built-ins"
LIB_PC_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/dri.pc:${PORTSDIR}/graphics/dri
USE_XORG+= pciaccess xextproto videoproto fontsproto dri2proto fontutil:build