aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>1997-11-20 05:31:44 +0000
committerSatoshi Asami <asami@FreeBSD.org>1997-11-20 05:31:44 +0000
commitcabb48a0101bbae50a1e4727d07f5194f5415ed1 (patch)
tree2bf49ea60b2caf31d94956dbea927f2e0d7e3cc7 /Mk
parentcca6f2268426982318bbd3faafc38f73f034450f (diff)
downloadports-cabb48a0101bbae50a1e4727d07f5194f5415ed1.tar.gz
ports-cabb48a0101bbae50a1e4727d07f5194f5415ed1.zip
Notes
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.subdir.mk30
1 files changed, 29 insertions, 1 deletions
diff --git a/Mk/bsd.port.subdir.mk b/Mk/bsd.port.subdir.mk
index 00cf49fad682..2c70232418dc 100644
--- a/Mk/bsd.port.subdir.mk
+++ b/Mk/bsd.port.subdir.mk
@@ -1,5 +1,5 @@
# from: @(#)bsd.subdir.mk 5.9 (Berkeley) 2/1/91
-# $Id: bsd.port.subdir.mk,v 1.21 1997/11/06 02:20:27 fenner Exp $
+# $Id: bsd.port.subdir.mk,v 1.22 1997/11/10 00:35:25 wosch Exp $
#
# The include file <bsd.port.subdir.mk> contains the default targets
# for building ports subdirectories.
@@ -97,6 +97,34 @@ afterinstall: realinstall
realinstall: beforeinstall _SUBDIRUSE
.endif
+IGNOREDIR= CVS distfiles packages pkg templates
+
+.if !target(checksubdirs)
+.if defined(PORTSTOP)
+checksubdirs: checksubdir _SUBDIRUSE
+.else
+checksubdirs: checksubdir
+.endif
+.endif
+
+.if !target(checksubdir)
+checksubdir:
+ @for d in *; do \
+ if [ -d "$$d" ]; then \
+ found=0; \
+ for s in ${SUBDIR} ${IGNOREDIR}; do \
+ if [ "x$$s" = "x$$d" ]; then \
+ found=1; \
+ break; \
+ fi; \
+ done; \
+ if [ $$found = 0 ]; then \
+ ${ECHO} "Warning: directory $$d not in SUBDIR"; \
+ fi; \
+ fi; \
+ done
+.endif
+
.if !target(readmes)
readmes: readme _SUBDIRUSE
.endif