aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2021-09-24 07:29:28 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2021-09-24 15:09:09 +0000
commit4d10eef66bb959ed0433df9e065458af4c325552 (patch)
treec479c0b479d95640ecc4e019cb72e4f58284a8f0 /Mk
parent6ae8585b1e25383a713d1c23ab1d9b34079c37f6 (diff)
downloadports-4d10eef66bb959ed0433df9e065458af4c325552.tar.gz
ports-4d10eef66bb959ed0433df9e065458af4c325552.zip
x11-toolkits/qt5-declarative: split out 'test' parts into new port
kde@ has been focused recently on reducing the load of "unnecessary" runtime dependencies, to allow third party distributions to have a leaner installation. One part of this effort was to make qt5-testlib a "build only" dependency. Unfortunately, parts of qt5-declarative link against testlib (to provide test functionality for declarative parts). This lead to an unfortunate loop of pkg-autoremove removing testlib, and then pkg-update adding it again (as it was an improperly registered dependency). This change splits out the "test"-parts into its own port. Thereby making testlib not even a required build-time dependency for x11-toolkits/qt5-delcarative. Reported by: jrm Differential Revision: https://reviews.freebsd.org/D32097
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/qt.mk5
1 files changed, 4 insertions, 1 deletions
diff --git a/Mk/Uses/qt.mk b/Mk/Uses/qt.mk
index 932d1fd4cd0e..a91f4d407e46 100644
--- a/Mk/Uses/qt.mk
+++ b/Mk/Uses/qt.mk
@@ -127,7 +127,7 @@ _USES_POST+= qt
_QT_MK_POST_INCLUDED= qt.mk
# The Qt components supported by qt.mk: list of shared, and version specific ones
-_USE_QT_ALL= assistant dbus declarative designer doc gui help \
+_USE_QT_ALL= assistant dbus declarative declarative-test designer doc gui help \
imageformats l10n linguist linguisttools multimedia \
network opengl pixeltool qdbusviewer qmake script \
scripttools sql sql-mysql sql-odbc sql-pgsql \
@@ -177,6 +177,9 @@ qt-dbus_LIB= libQt${_QT_LIBVER}DBus.so
qt-declarative_PORT= x11-toolkits/${_QT_RELNAME}-declarative
qt-declarative_LIB= libQt${_QT_LIBVER}Qml.so
+qt-declarative-test_PORT= x11-toolkits/${_QT_RELNAME}-declarative-test
+qt-declarative-test_LIB= libQt${_QT_LIBVER}QuickTest.so
+
qt-designer_PORT= devel/${_QT_RELNAME}-designer
qt-designer_PATH= ${LOCALBASE}/${QT_BINDIR_REL}/designer