aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2021-08-13 20:36:12 +0000
committerBryan Drewery <bdrewery@FreeBSD.org>2021-08-13 20:36:12 +0000
commitbed9a4de0ee7f955fc1a9a01cbc9a7e601aafd5f (patch)
treef0ebd050ad3eeef1c85ae071532c3e89664c31c0 /Mk
parent154492dd1f1d8c9a8f9c283f830a737c96e64a10 (diff)
downloadports-bed9a4de0ee7f955fc1a9a01cbc9a7e601aafd5f.tar.gz
ports-bed9a4de0ee7f955fc1a9a01cbc9a7e601aafd5f.zip
Mk/bsd.port.mk: Fix typo
Fixes: 154492dd1f ("Clarify UNAME_r failure.")
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 390b06262018..1135e6292e90 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1198,7 +1198,7 @@ _OSVERSION_MAJOR= ${OSVERSION:C/([0-9]?[0-9])([0-9][0-9])[0-9]{3}/\1/}
.if defined(I_DONT_CARE_IF_MY_BUILDS_TARGET_THE_WRONG_RELEASE)
WARNING+= "I_DONT_CARE_IF_MY_BUILDS_TARGET_THE_WRONG_RELEASE set: Expect unexpected problems as the chroot/jail file versions do not match what `uname` returns. Thus buids will target the wrong release."
.else
-.error UNAME_r (${_OSRELEASE}) and OSVERSION (${OSVERSION}) do not agree on major version number: This means your jail or chroot is misconfigured such that the installed files (OSVERION) do not match what `uname -r` (kernel) treturns. Likely setting UNAME_r will resolve the issue. OSVERSION should not be set as it will be read from /usr/include/sys/param.h.
+.error UNAME_r (${_OSRELEASE}) and OSVERSION (${OSVERSION}) do not agree on major version number: This means your jail or chroot is misconfigured such that the installed files (OSVERION) do not match what `uname -r` (kernel) returns. Likely setting UNAME_r will resolve the issue. OSVERSION should not be set as it will be read from /usr/include/sys/param.h.
.endif
.elif ${_OSVERSION_MAJOR} != ${OSREL:R}
.error OSREL (${OSREL}) and OSVERSION (${OSVERSION}) do not agree on major version number.