aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2013-04-02 14:01:27 +0000
committerMartin Wilke <miwi@FreeBSD.org>2013-04-02 14:01:27 +0000
commit0e67efc529bf87395f990fa90bd19fb1531078a7 (patch)
tree800fc7ca0ab0cb4e903963353a4ad64c97d8b00d /Mk
parentc5b490e1df1eb4df1fa1ec693e8dc3140ec3f06f (diff)
downloadports-0e67efc529bf87395f990fa90bd19fb1531078a7.tar.gz
ports-0e67efc529bf87395f990fa90bd19fb1531078a7.zip
Notes
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.gecko.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/Mk/bsd.gecko.mk b/Mk/bsd.gecko.mk
index b54be8561ffe..b7380380d03b 100644
--- a/Mk/bsd.gecko.mk
+++ b/Mk/bsd.gecko.mk
@@ -553,15 +553,15 @@ LDFLAGS+= -Wl,-rpath,${PREFIX}/lib/${MOZ_RPATH}
.if ${MOZILLA_VER:R:R} >= 19 || ${MOZILLA:Mseamonkey*}
# prefer clang
-. if ${CC} == "cc" && (exists(/usr/bin/clang) || \
+. if ${CC} == "cc" && (exists(/usr/bin/clang) && ${OSVERSION} >= 900014 || \
exists(${LOCALBASE}/bin/clang))
CC= clang
. endif
-. if ${CXX} == "c++" && (exists(/usr/bin/clang++) || \
+. if ${CXX} == "c++" && (exists(/usr/bin/clang++) && ${OSVERSION} >= 900014 || \
exists(${LOCALBASE}/bin/clang++))
CXX= clang++
. endif
-. if ${CPP} == "cpp" && (exists(/usr/bin/clang-cpp) || \
+. if ${CPP} == "cpp" && (exists(/usr/bin/clang-cpp) && ${OSVERSION} >= 900014 || \
exists(${LOCALBASE}/bin/clang-cpp))
CPP= clang-cpp
. endif