aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2013-08-05 19:43:39 +0000
committerMatthias Andree <mandree@FreeBSD.org>2013-08-05 19:43:39 +0000
commit116922e712f1e3c1f74d1ae8fe3e21e0a4ae20e9 (patch)
tree353ea1860aa94d26c0fe86d2a956f39c4460bfd6 /Mk
parent1a87e77b6df1f52cdbb41195ef77b95e49c18fa9 (diff)
downloadports-116922e712f1e3c1f74d1ae8fe3e21e0a4ae20e9.tar.gz
ports-116922e712f1e3c1f74d1ae8fe3e21e0a4ae20e9.zip
Notes
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.database.mk10
1 files changed, 7 insertions, 3 deletions
diff --git a/Mk/bsd.database.mk b/Mk/bsd.database.mk
index 186bf2aab0e2..0adcd31be0a7 100644
--- a/Mk/bsd.database.mk
+++ b/Mk/bsd.database.mk
@@ -283,7 +283,7 @@ LDFLAGS+= -L${LOCALBASE}/lib
.if defined(USE_BDB)
-_DB_PORTS= 40 41 42 43 44 46 47 48 5 40+ 41+ 42+ 43+ 44+ 46+ 47+ 48+
+_DB_PORTS= 40 41 42 43 44 46 47 48 5 6 40+ 41+ 42+ 43+ 44+ 46+ 47+ 48+ 5+ 6+
# Dependence lines for different db versions
db40_DEPENDS= libdb4.so:${PORTSDIR}/databases/db4
db41_DEPENDS= libdb41.so:${PORTSDIR}/databases/db41
@@ -420,8 +420,10 @@ _BDB_IGNORE= yes
IGNORE= cannot install: does not work with Berkeley DB version ${_BDB_VER} (${INVALID_BDB_VER} not supported)
. else
# Now add the dependency on Berkeley DB ${_BDB_VER) version
+# This is for ports that want to link Berkeley DB statically, such
+# as devel/subversion, if the corresponding option is active:
.if defined(BDB_BUILD_DEPENDS)
-BUILD_DEPENDS+= ${db${_BDB_VER}_FIND}:${db${_BDB_VER}_DEPENDS:C/^db.*://}
+BUILD_DEPENDS+= ${db${_BDB_VER}_FIND}:${db${_BDB_VER}_DEPENDS:C/^libdb.*://}
.else
LIB_DEPENDS+= ${db${_BDB_VER}_DEPENDS}
.endif
@@ -470,7 +472,9 @@ BDB_LIB_DIR?= ${LOCALBASE}/lib
BDB_VER= ${_BDB_VER}
.endif
-# Obsolete variables
+# Obsolete variables - ports can define these to want users about
+# variables that may be in /etc/make.conf but that are no longer
+# effective:
.if defined(OBSOLETE_BDB_VAR)
. for var in ${OBSOLETE_BDB_VAR}
. if defined(${var})