aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2001-11-17 21:23:09 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2001-11-17 21:23:09 +0000
commit5493715c6719193ded70822c8f99910bb389feab (patch)
treec09eeb4f17f17caa2d07de3bb973c7a06564a3c6 /Mk
parente00f2927631103fb3a9b115c32ba96d72e93c149 (diff)
downloadports-5493715c6719193ded70822c8f99910bb389feab.tar.gz
ports-5493715c6719193ded70822c8f99910bb389feab.zip
Notes
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk13
1 files changed, 11 insertions, 2 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index fe9d9b9adf21..6c85c38e234b 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -68,7 +68,7 @@ FreeBSD_MAINTAINER= portmgr@FreeBSD.org
# patches (default: none). make will look for them at
# PATCH_SITES (see below). They will automatically be
# uncompressed before patching if the names end with
-# ".gz" or ".Z".
+# ".gz", ".bz2" or ".Z".
# PATCH_SITES - Primary location(s) for distribution patch files
# if not found locally.
# DIST_SUBDIR - Suffix to ${DISTDIR}. If set, all ${DISTFILES}
@@ -809,7 +809,13 @@ MANCOMPRESSED?= yes
MANCOMPRESSED?= no
.endif
-.if defined(USE_BZIP2) && !exists(/usr/bin/bzip2)
+.if defined(PATCHFILES)
+.if ${PATCHFILES:M*.bz2}x != x
+HAVE_BZIP2_PATCHES= yes
+.endif
+.endif
+
+.if (defined(USE_BZIP2) || defined(HAVE_BZIP2_PATCHES)) && !exists(/usr/bin/bzip2)
BUILD_DEPENDS+= bzip2:${PORTSDIR}/archivers/bzip2
.endif
.if defined(USE_ZIP)
@@ -1790,6 +1796,9 @@ do-patch:
*.Z|*.gz) \
${GZCAT} $$i | ${PATCH} ${PATCH_DIST_ARGS}; \
;; \
+ *.bz2) \
+ ${BZCAT} $$i | ${PATCH} ${PATCH_DIST_ARGS}; \
+ ;; \
*) \
${PATCH} ${PATCH_DIST_ARGS} < $$i; \
;; \