aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2006-07-05 19:53:27 +0000
committerMark Linimon <linimon@FreeBSD.org>2006-07-05 19:53:27 +0000
commit6728fa2af2a7ecb3ec784490c7246233ab6c5040 (patch)
tree8c1bc70b60f297442386f03416f84bb99ee2b55a /Mk
parent44f5fbd656d36084c51de9ef66921e16c6518e01 (diff)
downloadports-6728fa2af2a7ecb3ec784490c7246233ab6c5040.tar.gz
ports-6728fa2af2a7ecb3ec784490c7246233ab6c5040.zip
Notes
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.scons.mk20
1 files changed, 10 insertions, 10 deletions
diff --git a/Mk/bsd.scons.mk b/Mk/bsd.scons.mk
index c09525b6eb2a..950b9a0f6aec 100644
--- a/Mk/bsd.scons.mk
+++ b/Mk/bsd.scons.mk
@@ -20,14 +20,14 @@ SCONS_MAINTAINER= alex@foxybanana.com
SCONS_BIN= ${LOCALBASE}/bin/scons
SCONS_PORT= ${PORTSDIR}/devel/scons
-#
+#
# CCFLAGS is the scons equivalent of CFLAGS. So we should bring in our
# FreeBSD CFLAGS.
#
# LINKFLAGS is equivalent to LDFLAGS in make speak, so we bring in the
# FreeBSD default LDFLAGS.
#
-# Some scons projects may honor PKGCONFIGDIR, which tells them where to
+# Some scons projects may honor PKGCONFIGDIR, which tells them where to
# look for, and install, pkgconfig files.
#
CCFLAGS?= ${CFLAGS}
@@ -38,15 +38,15 @@ CCFLAGS+= -I${LOCALBASE}/include
CXXFLAGS+= -I${LOCALBASE}/include
LINKFLAGS+= -L${LOCALBASE}/lib
-#
+#
# SCONS_ENV is where we pass all the stuff that should be the
# same for any scons port to scons. Things like CCFLAGS, and LINKFLAGS
# go here.
#
-# SCONS_ARG is where you pass port specific scons flags to the scons
+# SCONS_ARG is where you pass port specific scons flags to the scons
# enviornment.
#
-# SCONS_BUILDENV is where you pass variables you want to be in the
+# SCONS_BUILDENV is where you pass variables you want to be in the
# System Enviornment instead of the SCons Enviornment.
#
# SCONS_TARGET is the same as MAKE_TARGET it is passed as the last
@@ -55,20 +55,20 @@ LINKFLAGS+= -L${LOCALBASE}/lib
SCONS_ENV?= CCFLAGS="${CCFLAGS}" CXXFLAGS="${CXXFLAGS}" \
LINKFLAGS="${LINKFLAGS}" PKGCONFIGDIR="${PKGCONFIGDIR}" \
PREFIX="${PREFIX}" CC="${CC}" CXX="${CXX}"
-SCONS_ARGS?=
-SCONS_BUILDENV?=
+SCONS_ARGS?=
+SCONS_BUILDENV?=
SCONS_TARGET?=
#
-# SCONS_INSTALL_TARGET is the default target to be used when
+# SCONS_INSTALL_TARGET is the default target to be used when
# installing a port using scons.
#
SCONS_INSTALL_TARGET?= ${INSTALL_TARGET}
-#
+#
# Make sure we depend on scons
#
-BUILD_DEPENDS+= ${SCONS_BIN}:${SCONS_PORT}
+BUILD_DEPENDS+= ${SCONS_BIN}:${SCONS_PORT}
.if !target(do-build)
do-build: