aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2007-02-04 20:23:37 +0000
committerKris Kennaway <kris@FreeBSD.org>2007-02-04 20:23:37 +0000
commitbfb0242e1eaeb2132c57226624ef47c781860d05 (patch)
tree13b17a9d3acd2f257a36df3c117be446c4bc6232 /Mk
parent31dd71ff135a6275800fd18544c28ff9afe35ffb (diff)
downloadports-bfb0242e1eaeb2132c57226624ef47c781860d05.tar.gz
ports-bfb0242e1eaeb2132c57226624ef47c781860d05.zip
Notes
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk13
-rw-r--r--Mk/bsd.port.subdir.mk4
2 files changed, 2 insertions, 15 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 63cc50c0f474..71c0ca32ec2d 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -46,7 +46,6 @@ FreeBSD_MAINTAINER= portmgr@FreeBSD.org
# "FreeBSD," "NetBSD," or "OpenBSD" as appropriate.
# OSREL - The release version (numeric) of the operating system.
# OSVERSION - The value of __FreeBSD_version.
-# PORTOBJFORMAT - The object format ("aout" or "elf").
#
# This is the beginning of the list of all variables that need to be
# defined in a port, listed in order that they should be included
@@ -1171,11 +1170,6 @@ OSVERSION!= ${SYSCTL} -n kern.osreldate
.endif
.endif
-# Get the object format.
-.if !defined(PORTOBJFORMAT)
-PORTOBJFORMAT?= elf
-.endif
-
MASTERDIR?= ${.CURDIR}
.if ${MASTERDIR} != ${.CURDIR}
@@ -1663,10 +1657,8 @@ PLIST_SUB+= PORTDOCS=""
CONFIGURE_SHELL?= ${SH}
MAKE_SHELL?= ${SH}
-CONFIGURE_ENV+= SHELL=${SH} CONFIG_SHELL=${SH} PORTOBJFORMAT=${PORTOBJFORMAT}
-SCRIPTS_ENV+= PORTOBJFORMAT=${PORTOBJFORMAT}
-MAKE_ENV+= SHELL=${SH} PORTOBJFORMAT=${PORTOBJFORMAT} NO_LINT=YES
-PLIST_SUB+= PORTOBJFORMAT=${PORTOBJFORMAT}
+CONFIGURE_ENV+= SHELL=${SH} CONFIG_SHELL=${SH}
+MAKE_ENV+= SHELL=${SH} NO_LINT=YES
.if defined(MANCOMPRESSED)
.if ${MANCOMPRESSED} != yes && ${MANCOMPRESSED} != no && \
@@ -5659,7 +5651,6 @@ __softMAKEFLAGS+= '${softvar}+=${${softvar}:S/'/'\''/g}'
OPSYS="${OPSYS:S/"/"'"'"/g:S/\$/\$\$/g:S/\\/\\\\/g}" \
OSREL="${OSREL:S/"/"'"'"/g:S/\$/\$\$/g:S/\\/\\\\/g}" \
OSVERSION="${OSVERSION:S/"/"'"'"/g:S/\$/\$\$/g:S/\\/\\\\/g}" \
- PORTOBJFORMAT="${PORTOBJFORMAT:S/"/"'"'"/g:S/\$/\$\$/g:S/\\/\\\\/g}" \
SYSTEMVERSION="${SYSTEMVERSION:S/"/"'"'"/g:S/\$/\$\$/g:S/\\/\\\\/g}"
.endif
diff --git a/Mk/bsd.port.subdir.mk b/Mk/bsd.port.subdir.mk
index 0f93ac07a39a..54b58cf7da67 100644
--- a/Mk/bsd.port.subdir.mk
+++ b/Mk/bsd.port.subdir.mk
@@ -60,9 +60,6 @@ OSVERSION!= /sbin/sysctl -n kern.osreldate
OSVERSION!= /usr/sbin/sysctl -n kern.osreldate
.endif
.endif
-.if !defined(PORTOBJFORMAT)
-PORTOBJFORMAT?= elf
-.endif
.endif
ID?= ${DESTDIR}/usr/bin/id
@@ -322,7 +319,6 @@ README.html:
OPSYS="${OPSYS:S/"/"'"'"/g:S/\$/\$\$/g:S/\\/\\\\/g}" \
OSREL="${OSREL:S/"/"'"'"/g:S/\$/\$\$/g:S/\\/\\\\/g}" \
OSVERSION="${OSVERSION:S/"/"'"'"/g:S/\$/\$\$/g:S/\\/\\\\/g}" \
- PORTOBJFORMAT="${PORTOBJFORMAT:S/"/"'"'"/g:S/\$/\$\$/g:S/\\/\\\\/g}" \
UID="${UID:S/"/"'"'"/g:S/\$/\$\$/g:S/\\/\\\\/g}" \
PKGINSTALLVER="${PKGINSTALLVER:S/"/"'"'"/g:S/\$/\$\$/g:S/\\/\\\\/g}"
.endif