aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-05-31 05:04:04 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-05-31 05:04:04 +0000
commitb5ddd364f18ab3af45e50b2892ec317d5dc6c9d3 (patch)
treefed65f897d6a01dfd4062ff27006494e3bd009f5 /Mk
parentd0396a28d93ac4185e13a8cf7b0bb6e583714589 (diff)
downloadports-b5ddd364f18ab3af45e50b2892ec317d5dc6c9d3.tar.gz
ports-b5ddd364f18ab3af45e50b2892ec317d5dc6c9d3.zip
Notes
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk14
1 files changed, 7 insertions, 7 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 9bfb2dfa17a9..271ca1415e35 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -5997,18 +5997,18 @@ pre-config:
_COMPLETE_OPTIONS_LIST:= ${ALL_OPTIONS}
.for opt in ${ALL_OPTIONS}
. if empty(PORT_OPTIONS:M${opt})
-DEFOPTIONS+= ${opt} "${${opt}_DESC:S|"||g:S|'| |g}" off
+DEFOPTIONS+= ${opt} ${${opt}_DESC:Q} off
. else
-DEFOPTIONS+= ${opt} "${${opt}_DESC:S|"||g:S|'| |g}" on
+DEFOPTIONS+= ${opt} ${${opt}_DESC:Q} on
. endif
.endfor
.for multi in ${OPTIONS_MULTI}
. for opt in ${OPTIONS_MULTI_${multi}}
_COMPLETE_OPTIONS_LIST+= ${opt}
. if empty(PORT_OPTIONS:M${opt})
-DEFOPTIONS+= ${opt} "M(${multi}): ${${opt}_DESC:S|"||g:S|'| |g}" off
+DEFOPTIONS+= ${opt} "M(${multi}): "${${opt}_DESC:Q} off
. else
-DEFOPTIONS+= ${opt} "M(${multi}): ${${opt}_DESC:S|"||g:S|'| |g}" on
+DEFOPTIONS+= ${opt} "M(${multi}): "${${opt}_DESC:Q} on
. endif
. endfor
.endfor
@@ -6016,9 +6016,9 @@ DEFOPTIONS+= ${opt} "M(${multi}): ${${opt}_DESC:S|"||g:S|'| |g}" on
. for opt in ${OPTIONS_SINGLE_${single}}
_COMPLETE_OPTIONS_LIST+= ${opt}
. if empty(PORT_OPTIONS:M${opt})
-DEFOPTIONS+= ${opt} "S(${single}): ${${opt}_DESC:S|"||g:S|'| |g}" off
+DEFOPTIONS+= ${opt} "S(${single}): "${${opt}_DESC:Q} off
. else
-DEFOPTIONS+= ${opt} "S(${single}): ${${opt}_DESC:S|"||g:S|'| |g}" on
+DEFOPTIONS+= ${opt} "S(${single}): "${${opt}_DESC:Q} on
. endif
. endfor
.endfor
@@ -6047,7 +6047,7 @@ config: pre-config
.endif
@TMPOPTIONSFILE=$$(mktemp -t portoptions); \
trap "${RM} -f $${TMPOPTIONSFILE}; exit 1" 1 2 3 5 10 13 15; \
- ${SH} -c '${DIALOG} --checklist "Options for ${PKGNAME:C/-([^-]+)$/ \1/}" 21 70 15 ${DEFOPTIONS}' 2> $${TMPOPTIONSFILE} || { \
+ ${DIALOG} --checklist "Options for ${PKGNAME:C/-([^-]+)$/ \1/}" 21 70 15 ${DEFOPTIONS} 2> $${TMPOPTIONSFILE} || { \
${RM} -f $${TMPOPTIONSFILE}; \
${ECHO_MSG} "===> Options unchanged"; \
exit 0; \