aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-03-06 16:52:02 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-03-06 16:52:02 +0000
commitda12e6723dd1adee8b0c5e4b081caecab544e684 (patch)
treec2364f5819e8d5e433572c797bab46ab06e70b04 /Mk
parentffc075db2e24d843dce270ae2b5a694a70b5b18c (diff)
Notes
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/fuse.mk15
-rw-r--r--Mk/bsd.port.mk10
2 files changed, 15 insertions, 10 deletions
diff --git a/Mk/Uses/fuse.mk b/Mk/Uses/fuse.mk
new file mode 100644
index 000000000000..3f58941fb884
--- /dev/null
+++ b/Mk/Uses/fuse.mk
@@ -0,0 +1,15 @@
+# $FreeBSD$
+#
+# handle dependency on the fuse port
+#
+# MAINTAINER: portmgr@FreeBSD.org
+#
+.if !defined(_INCLUDE_FUSE_MK)
+_INCLUDE_FUSE_MK= yes
+
+LIB_DEPENDS+= fuse:${PORTSDIR}/sysutils/fusefs-libs
+.if !exists(/sbin/mount_fusefs)
+RUN_DEPENDS+= mount_fusefs:${PORTSDIR}/sysutils/fusefs-kmod
+.endif
+
+.endif
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 7d8b8919fec7..9ca06919450b 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -408,9 +408,6 @@ FreeBSD_MAINTAINER= portmgr@FreeBSD.org
# - Legal values are: gamin (default),fam
# If set to an unknown value, the port is marked IGNORE.
##
-# USE_FUSE - If set, make sure necessary components unavailable in base
-# are installed from ports.
-##
# USE_AUTOTOOLS - If set, this port uses various GNU autotools
# (libtool, autoconf, autoheader, automake et al.)
# See bsd.autotools.mk for more details.
@@ -1854,13 +1851,6 @@ IGNORE= cannot be built with unknown FAM system: ${FAM_SYSTEM}
.endif
.endif # USE_FAM
-.if defined(USE_FUSE)
-LIB_DEPENDS+= fuse:${PORTSDIR}/sysutils/fusefs-libs
-.if !exists(/sbin/mount_fusefs)
-RUN_DEPENDS+= mount_fusefs:${PORTSDIR}/sysutils/fusefs-kmod
-.endif
-.endif
-
.if defined(USE_RC_SUBR) && ${USE_RC_SUBR:U} != "YES"
SUB_FILES+= ${USE_RC_SUBR}
.endif