aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2013-03-02 01:06:15 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2013-03-02 01:06:15 +0000
commite819edf526765f2f087d87ec3130856198c64d73 (patch)
tree0cd3a1561c419d8333e7e8cc174cd8aced8c7420 /Mk
parentcae75110cc2937087576c178ff441b74c955b14b (diff)
Notes
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.gcc.mk6
1 files changed, 1 insertions, 5 deletions
diff --git a/Mk/bsd.gcc.mk b/Mk/bsd.gcc.mk
index 6b4a0cb052c3..6bf8a1713683 100644
--- a/Mk/bsd.gcc.mk
+++ b/Mk/bsd.gcc.mk
@@ -143,20 +143,16 @@ IGNORE= Unknown version of GCC specified (USE_GCC=${USE_GCC})
.endif
#
-# Determine current GCCVERSION
+# Initialize _GCC_FOUND${v}.
#
.for v in ${GCCVERSIONS}
. if exists(${LOCALBASE}/bin/gcc${_GCCVERSION_${v}_V:S/.//})
_GCC_FOUND${v}= port
. endif
. if ${OSVERSION} >= ${_GCCVERSION_${v}_L} && ${OSVERSION} < ${_GCCVERSION_${v}_R}
-_GCCVERSION:= ${v}
_GCC_FOUND${v}:= base
. endif
.endfor
-.if !defined(_GCCVERSION)
-IGNORE= Couldn't find your current GCCVERSION (OSVERSION=${OSVERSION})
-.endif
#
# If the GCC package defined in USE_GCC does not exist, but a later