aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2016-02-07 19:43:56 +0000
committerKoop Mast <kwm@FreeBSD.org>2016-02-07 19:43:56 +0000
commit71d5deb1f423658f8c3e3a0baa54dd883dd5d8d8 (patch)
tree9e818b5d09f2e948238e96c1a5ae1e8212983272 /Mk
parentbca3635bdcc45f8ac6cd82e879aa2679870f2975 (diff)
downloadports-71d5deb1f423658f8c3e3a0baa54dd883dd5d8d8.tar.gz
ports-71d5deb1f423658f8c3e3a0baa54dd883dd5d8d8.zip
Notes
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/gnome.mk (renamed from Mk/bsd.gnome.mk)51
-rw-r--r--Mk/Uses/mate.mk (renamed from Mk/bsd.mate.mk)47
-rw-r--r--Mk/bsd.port.mk22
3 files changed, 48 insertions, 72 deletions
diff --git a/Mk/bsd.gnome.mk b/Mk/Uses/gnome.mk
index 485dfec2967c..c1141470e5ae 100644
--- a/Mk/bsd.gnome.mk
+++ b/Mk/Uses/gnome.mk
@@ -1,4 +1,4 @@
-#-*- tab-width: 4; -*-
+#-*- mode: Fundamental; tab-width: 4; -*-
# ex:ts=4
#
# $FreeBSD$
@@ -13,12 +13,8 @@
#
# ======================= /USERS ================================
-.if !defined(_POSTMKINCLUDED) && !defined(Gnome_Pre_Include)
-
# Please make sure all changes to this file are passed through the maintainer.
# Do not commit them yourself (unless of course you're the Port's Wraith ;).
-Gnome_Include_MAINTAINER= gnome@FreeBSD.org
-Gnome_Pre_Include= bsd.gnome.mk
# This section defines possible names of GNOME components and all information
# necessary for ports to use those components.
@@ -59,6 +55,16 @@ Gnome_Pre_Include= bsd.gnome.mk
# and will display correctly. This macro isn't needed
# for QT based applications, which use a different method.
#
+# MAINTAINER: gnome@FreeBSD.org
+
+.if !defined(_INCLUDE_USES_GNOME_MK)
+_INCLUDE_USES_GNOME_MK= yes
+
+_USES_POST+= gnome
+
+.if !empty(gnome_ARGS)
+IGNORE= USES=gnome takes no arguments
+.endif
# non-version specific components
_USE_GNOME_ALL= esound intlhack intltool introspection \
@@ -554,17 +560,6 @@ HAVE_GNOME+= ${component}
. endif
.endif
-.endif
-# End of optional part.
-
-.if defined(_POSTMKINCLUDED) && !defined(Gnome_Post_Include)
-
-Gnome_Post_Include= bsd.gnome.mk
-
-.if !defined(Gnome_Pre_Include)
-.error The Pre include part of bsd.gnome.mk part is not included. Did you forget WANT_GNOME=yes before bsd.port.pre.mk?
-.endif
-
.if defined(USE_GNOME)
# First of all expand all USE_GNOME_IMPL recursively
. for component in ${_USE_GNOME_ALL}
@@ -653,14 +648,6 @@ MAKE_ENV+= GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
. endif
.endif
-.if defined(GNOME_PRE_PATCH)
-
-pre-patch: gnome-pre-patch
-
-gnome-pre-patch:
- @${GNOME_PRE_PATCH:C/^;//1}
-.endif
-
.if defined(WANT_GNOME)
USE_GNOME?=
. if ${_USE_GNOME_SAVED}==${USE_GNOME}
@@ -676,9 +663,23 @@ RUN_DEPENDS+= ${GNOME_SUBR}:${PORTSDIR}/sysutils/gnome_subr
SUB_LIST+= GNOME_SUBR=${GNOME_SUBR}
.endif
+.endif
+# end of the part
+
+.if defined(_POSTMKINCLUDED) && !defined(_INCLUDE_USES_GNOME_POST_MK)
+_INCLUDE_USES_GNOME_POST_MK= yes
+
+.if defined(GNOME_PRE_PATCH)
+
+_USES_patch+= 290:gnome-pre-patch
+
+gnome-pre-patch:
+ @${GNOME_PRE_PATCH:C/^;//1}
+.endif
+
.if defined(GCONF_SCHEMAS) || defined(INSTALLS_OMF) || defined(INSTALLS_ICONS) \
|| defined(GLIB_SCHEMAS)
-post-install: gnome-post-install
+_USES_install+= 690:gnome-post-install
gnome-post-install:
. if defined(GCONF_SCHEMAS)
diff --git a/Mk/bsd.mate.mk b/Mk/Uses/mate.mk
index d7e4aff2c4f2..9aa59b945d57 100644
--- a/Mk/bsd.mate.mk
+++ b/Mk/Uses/mate.mk
@@ -2,31 +2,29 @@
# ex:ts=4
#
# $FreeBSD$
-# $NetBSD$
-# $MCom: ports-experimental/Mk/bsd.mate.mk,v 1.13 2012/09/03 17:02:31 mezz Exp $
#
# Please view me with 4 column tabs!
-#######################################################
-#
-# *** WARNING: Disable MARCUSCOM before merge in FreeBSD!
-# Please also remove this section before merging into FreeBSD.
-#
-#MARCUSCOM_CVS=yes
-
# ======================= USERS =================================
#
# There are no significant user-definable settings in here.
# This file is a framework to make it easier to create MATE ports.
#
# ======================= /USERS ================================
-
-.if !defined(_POSTMKINCLUDED) && !defined(Mate_Pre_Include)
-
+#
# Please make sure all changes to this file are passed through the maintainer.
# Do not commit them yourself (unless of course you're the Port's Wraith ;).
-Mate_Include_MAINTAINER= gnome@FreeBSD.org
-Mate_Pre_Include= bsd.mate.mk
+#
+# MAINTAINER: gnome@FreeBSD.org
+
+.if !defined(_INCLUDE_USES_MATE_MK)
+_INCLUDE_USES_MATE_MK= yes
+
+_USES_POST+= mate
+
+.if !empty(mate_ARGS)
+IGNORE= USES=mate takes no arguments
+.endif
# This section defines possible names of MATE components and all information
# necessary for ports to use those components.
@@ -142,13 +140,6 @@ settingsdaemon_RUN_DEPENDS= ${settingsdaemon_DETECT}:${PORTSDIR}/sysutils/mate-s
# End component definition section
-.endif
-# End of optional part.
-
-.if defined(_POSTMKINCLUDED) && !defined(Mate_Post_Include)
-
-Mate_Post_Include= bsd.mate.mk
-
.if defined(USE_MATE)
# Comparing between USE_MATE and _USE_MATE_ALL to make sure the component
# exists in _USE_MATE_ALL. If it does not exist then give an error about it.
@@ -202,11 +193,17 @@ MATE_PRE_PATCH+= ; ${${component}_PRE_PATCH}
. endfor
.endif # USE_MATE check
+.endif
+# End of optional part.
+
+.if defined(_POSTMKINCLUDED) && !defined(_INCLUDE_USES_MATE_POST_MK)
+_INCLUDE_USES_MATE_POST_MK= yes
+
.if ${USE_MATE:Mautogen}!=""
CONFIGURE_ENV+= NOCONFIGURE=yes
-pre-configure: mate-pre-configure
+_USES_configure+= 295:mate-pre-configure
mate-pre-configure:
@(cd ${CONFIGURE_WRKSRC} ; ${SETENV} ${CONFIGURE_ENV} ./autogen.sh)
@@ -214,15 +211,11 @@ mate-pre-configure:
.if defined(MATE_PRE_PATCH)
-pre-configure-script: mate-pre-configure-script
+_USES_configure+= 445:mate-pre-configure-script
mate-pre-configure-script:
@${MATE_PRE_PATCH:C/^;//1}
.endif
-.if ${MAINTAINER}=="gnome@FreeBSD.org"
-CONFIGURE_FAIL_MESSAGE= "Please run the gnomelogalyzer, available from \"http://www.freebsd.org/gnome/gnomelogalyzer.sh\", which will diagnose the problem and suggest a solution. If - and only if - the gnomelogalyzer cannot solve the problem, report the build failure to the FreeBSD MATE team at ${MAINTAINER}, and attach (a) \"${CONFIGURE_WRKSRC}/${CONFIGURE_LOG}\", (b) the output of the failed make command, and (c) the gnomelogalyzer output. Also, it might be a good idea to provide an overview of all packages installed on your system (i.e. an \`ls ${PKG_DBDIR}\`). Put your attachment up on any website, copy-and-paste into http://freebsd-gnome.pastebin.com, or use send-pr(1) with the attachment. Try to avoid sending any attachments to the mailing list (${MAINTAINER}), because attachments sent to FreeBSD mailing lists are usually discarded by the mailing list software."
-.endif
-
.endif
# End of use part.
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 6f199f71e6f3..b934a2113585 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -388,16 +388,6 @@ FreeBSD_MAINTAINER= portmgr@FreeBSD.org
# USE_GECKO - If set, this port uses the Gecko/Mozilla product.
# See bsd.gecko.mk for more details.
##
-# USE_GNOME - A list of the Gnome dependencies the port has (e.g.,
-# glib12, gtk12). Implies that the port needs Gnome.
-# Implies inclusion of bsd.gnome.mk. See bsd.gnome.mk
-# or http://www.FreeBSD.org/gnome/docs/porting.html
-# for more details.
-##
-# USE_MATE - A list of the MATE dependencies the port has. Implies
-# that the port needs MATE. Implies inclusion of
-# bsd.mate.mk. See bsd.mate.mk for more details.
-##
# USE_WX - If set, this port uses the WxWidgets library and related
# components. See bsd.wx.mk for more details.
##
@@ -1398,11 +1388,11 @@ PKGCOMPATDIR?= ${LOCALBASE}/lib/compat/pkg
.endif
.if defined(WANT_GNOME) || defined(USE_GNOME) || defined(INSTALLS_ICONS)
-.include "${PORTSDIR}/Mk/bsd.gnome.mk"
+USES+= gnome
.endif
.if defined(USE_MATE)
-.include "${PORTSDIR}/Mk/bsd.mate.mk"
+USES+= mate
.endif
.if defined(WANT_WX) || defined(USE_WX) || defined(USE_WX_NOT)
@@ -1913,14 +1903,6 @@ _FORCE_POST_PATTERNS= rmdir kldxref mkfontscale mkfontdir fc-cache \
.include "${PORTSDIR}/Mk/bsd.gecko.mk"
.endif
-.if defined(WANT_GNOME) || defined(USE_GNOME)
-.include "${PORTSDIR}/Mk/bsd.gnome.mk"
-.endif
-
-.if defined(USE_MATE)
-.include "${PORTSDIR}/Mk/bsd.mate.mk"
-.endif
-
.if defined(USE_KDE4)
.include "${PORTSDIR}/Mk/bsd.kde4.mk"
.endif