aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-06-17 16:03:43 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-06-17 16:03:43 +0000
commitb85a2f394efe9f4d33f945e9907539671dedbed5 (patch)
tree26e62961f9f6943e32f62483e64aadc841c918d3 /Mk
parent19a137e719fe063a5f8e6c540e6325c911962f58 (diff)
downloadports-b85a2f394efe9f4d33f945e9907539671dedbed5.tar.gz
ports-b85a2f394efe9f4d33f945e9907539671dedbed5.zip
Notes
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.autotools.mk19
1 files changed, 9 insertions, 10 deletions
diff --git a/Mk/bsd.autotools.mk b/Mk/bsd.autotools.mk
index e4b2d4b9dc3b..4cca0ef56e26 100644
--- a/Mk/bsd.autotools.mk
+++ b/Mk/bsd.autotools.mk
@@ -190,29 +190,28 @@ ${var:tu}_ENV+= ${AUTOTOOLS_VARS}
# Make targets
#---------------------------------------------------------------------------
+_USES_configure+=460:run-autotools-aclocal 461:run-autotools-autoconf \
+ 462:run-autotools-autoheader 463:run-autotools-automake
+
.if defined(_AUTOTOOL_rule_aclocal) && !target(run-autotools-aclocal)
-_USES_configure+= 460:run-autotools-aclocal
run-autotools-aclocal:
@(cd ${CONFIGURE_WRKSRC} && ${SETENV} ${AUTOTOOLS_ENV} ${ACLOCAL} \
${ACLOCAL_ARGS})
.endif
-.if defined(_AUTOTOOL_rule_automake) && !target(run-autotools-automake)
-_USES_configure+= 461:run-autotools-autoconf
-run-autotools-automake:
- @(cd ${CONFIGURE_WRKSRC} && ${SETENV} ${AUTOTOOLS_ENV} ${AUTOMAKE} \
- ${AUTOMAKE_ARGS})
-.endif
-
.if defined(_AUTOTOOL_rule_autoconf) && !target(run-autotools-autoconf)
-_USES_configure+= 462:run-autotools-autoheader
run-autotools-autoconf:
@(cd ${CONFIGURE_WRKSRC} && ${SETENV} ${AUTOTOOLS_ENV} ${AUTOCONF} \
${AUTOCONF_ARGS})
.endif
+.if defined(_AUTOTOOL_rule_automake) && !target(run-autotools-automake)
+run-autotools-automake:
+ @(cd ${CONFIGURE_WRKSRC} && ${SETENV} ${AUTOTOOLS_ENV} ${AUTOMAKE} \
+ ${AUTOMAKE_ARGS})
+.endif
+
.if defined(_AUTOTOOL_rule_autoheader) && !target(run-autotools-autoheader)
-_USES_configure+= 463:run-autotools-automake
run-autotools-autoheader:
@(cd ${CONFIGURE_WRKSRC} && ${SETENV} ${AUTOTOOLS_ENV} ${AUTOHEADER} \
${AUTOHEADER_ARGS})