aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2019-09-27 09:35:20 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2019-09-27 09:35:20 +0000
commitdeaa22d85c723390e0a8a8d18d783d82f9a07dcc (patch)
tree8f6d2407afa434eb97adf4d5cae76c4fd1897123 /Mk
parent3362bfdd01e4eb0461404cd0b9202132a26d27da (diff)
downloadports-deaa22d85c723390e0a8a8d18d783d82f9a07dcc.tar.gz
ports-deaa22d85c723390e0a8a8d18d783d82f9a07dcc.zip
lang/rust: Update to 1.38.0
- Force rebuild all consumers to catch regressions early Thanks to Mikaƫl Urankar for providing updated bootstraps for aarch64, armv6, armv7, powerpc64. Changes: https://blog.rust-lang.org/2019/09/26/Rust-1.38.0.html Tested by: jbeich, mikael.urankar@gmail.com, tobik With hat: rust Differential Revision: https://reviews.freebsd.org/D21778
Notes
Notes: svn path=/head/; revision=513013
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/cargo.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/Mk/Uses/cargo.mk b/Mk/Uses/cargo.mk
index c1bf1d60ce19..e6355945c738 100644
--- a/Mk/Uses/cargo.mk
+++ b/Mk/Uses/cargo.mk
@@ -43,7 +43,7 @@ DISTFILES+= ${CARGO_DIST_SUBDIR}/${_crate}.tar.gz:cargo_${_crate:C/[^a-zA-Z0-9_]
CARGO_BUILDDEP?= yes
.if ${CARGO_BUILDDEP:tl} == "yes"
-BUILD_DEPENDS+= ${RUST_DEFAULT}>=1.37.0:lang/${RUST_DEFAULT}
+BUILD_DEPENDS+= ${RUST_DEFAULT}>=1.38.0:lang/${RUST_DEFAULT}
.endif
# Location of cargo binary (default to lang/rust's Cargo binary)