aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorAndrey A. Chernov <ache@FreeBSD.org>1994-10-12 03:12:19 +0000
committerAndrey A. Chernov <ache@FreeBSD.org>1994-10-12 03:12:19 +0000
commit2915ba44e5c5753b83fa1a9f29dba74d8d4c9ef3 (patch)
tree7a8acbbc6ffce290b20e92d3224ffb654fe16a52 /Mk
parent29342fc00f921cf586b37ee1f757d5bface15a73 (diff)
downloadports-2915ba44e5c5753b83fa1a9f29dba74d8d4c9ef3.tar.gz
ports-2915ba44e5c5753b83fa1a9f29dba74d8d4c9ef3.zip
Notes
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk5
1 files changed, 3 insertions, 2 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 64c342c5401b..c9a1d1ceb76f 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -3,7 +3,7 @@
# bsd.port.mk - 940820 Jordan K. Hubbard.
# This file is in the public domain.
#
-# $Id: bsd.port.mk,v 1.49 1994/10/05 22:28:45 jkh Exp $
+# $Id: bsd.port.mk,v 1.50 1994/10/12 02:58:38 ache Exp $
#
# Please view me with 4 column tabs!
@@ -265,10 +265,11 @@ pre-configure:
# This is done with a .configure because configures are often expensive,
# and you don't want it done again gratuitously when you're trying to get
# a make of the whole tree to work.
-configure: extract pre-configure ${CONFIGURE_COOKIE}
+configure: extract ${CONFIGURE_COOKIE}
${CONFIGURE_COOKIE}:
@echo "===> Configuring for ${DISTNAME}"
+ ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} pre-configure
@if [ -d ${PATCHDIR} ]; then \
echo "===> Applying patches for ${DISTNAME}" ; \
for i in ${PATCHDIR}/patch-*; do \