aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-11-20 07:29:08 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-11-20 07:29:08 +0000
commit8635d31369e2cd94bcf1195c472482741c6d77fa (patch)
tree8d36d1b1541ae14710b4d13f58346144b0d190a2 /Mk
parent89bcd875ca036e8b5b64cadedd62202eb6bcf319 (diff)
downloadports-8635d31369e2cd94bcf1195c472482741c6d77fa.tar.gz
ports-8635d31369e2cd94bcf1195c472482741c6d77fa.zip
Notes
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/charsetfix.mk1
-rw-r--r--Mk/Uses/desktop-file-utils.mk1
-rw-r--r--Mk/Uses/display.mk1
-rw-r--r--Mk/Uses/dos2unix.mk1
-rw-r--r--Mk/Uses/kmod.mk1
-rw-r--r--Mk/Uses/pathfix.mk1
-rw-r--r--Mk/Uses/shared-mime-info.mk1
-rw-r--r--Mk/Uses/shebangfix.mk1
-rw-r--r--Mk/Uses/webplugin.mk1
9 files changed, 9 insertions, 0 deletions
diff --git a/Mk/Uses/charsetfix.mk b/Mk/Uses/charsetfix.mk
index 06aca3b1f394..15b267428c0a 100644
--- a/Mk/Uses/charsetfix.mk
+++ b/Mk/Uses/charsetfix.mk
@@ -18,6 +18,7 @@ IGNORE= USES=charsetfix does not require args
CHARSETFIX_MAKEFILEIN?= Makefile.in
+.PHONY: charsetfix-post-patch
post-patch: charsetfix-post-patch
charsetfix-post-patch:
diff --git a/Mk/Uses/desktop-file-utils.mk b/Mk/Uses/desktop-file-utils.mk
index 3e4a732df4d9..92ff6b1fcc1f 100644
--- a/Mk/Uses/desktop-file-utils.mk
+++ b/Mk/Uses/desktop-file-utils.mk
@@ -20,6 +20,7 @@ BUILD_DEPENDS+= update-desktop-database:${PORTSDIR}/devel/desktop-file-utils
RUN_DEPENDS+= update-desktop-database:${PORTSDIR}/devel/desktop-file-utils
# bolt our post-install target to post-install
+.PHONY: desktop-file-post-install
post-install: desktop-file-post-install
desktop-file-post-install:
diff --git a/Mk/Uses/display.mk b/Mk/Uses/display.mk
index 2d8d29dc0166..14eacd46f1cf 100644
--- a/Mk/Uses/display.mk
+++ b/Mk/Uses/display.mk
@@ -25,6 +25,7 @@ XVFBPORT!= port=0; while test -S /tmp/.X11-unix/X$${port} ; do port=$$(( port +
XVFBPIDFILE= /tmp/.xvfb-${XVFBPORT}.pid
MAKE_ENV+= DISPLAY=":${XVFBPORT}"
+.PHONY: start-display stop-display
pre-${display_ARGS}: start-display
post-${display_ARGS}: stop-display
diff --git a/Mk/Uses/dos2unix.mk b/Mk/Uses/dos2unix.mk
index f152d36d031a..dca6d681f9f0 100644
--- a/Mk/Uses/dos2unix.mk
+++ b/Mk/Uses/dos2unix.mk
@@ -15,6 +15,7 @@ _INCLUDE_USES_DOS2UNIX_MK= yes
_DOS2UNIX_ALL= yes
.endif
+.PHONY: dos2unix
pre-patch: dos2unix
dos2unix:
diff --git a/Mk/Uses/kmod.mk b/Mk/Uses/kmod.mk
index a83160dbf1f6..560c3ce4ff5e 100644
--- a/Mk/Uses/kmod.mk
+++ b/Mk/Uses/kmod.mk
@@ -33,6 +33,7 @@ MAKE_ENV+= KMODDIR="${KMODDIR}" SYSDIR="${SRC_BASE}/sys"
MAKE_ENV+= NO_XREF=yes
.endif
+.PHONY: kmod-preinstall kmod-post-install
pre-install: kmod-pre-install
kmod-pre-install:
.if defined(NO_STAGE)
diff --git a/Mk/Uses/pathfix.mk b/Mk/Uses/pathfix.mk
index b44515a483c7..08068aa78399 100644
--- a/Mk/Uses/pathfix.mk
+++ b/Mk/Uses/pathfix.mk
@@ -19,6 +19,7 @@ IGNORE= USES=pathfix does not require args
PATHFIX_MAKEFILEIN?= Makefile.in
+.PHONY: pathfix-pre-patch
pre-patch: pathfix-pre-patch
pathfix-pre-patch:
diff --git a/Mk/Uses/shared-mime-info.mk b/Mk/Uses/shared-mime-info.mk
index 7c59eaff86af..cb4c62ea4e41 100644
--- a/Mk/Uses/shared-mime-info.mk
+++ b/Mk/Uses/shared-mime-info.mk
@@ -20,6 +20,7 @@ BUILD_DEPENDS+= update-mime-database:${PORTSDIR}/misc/shared-mime-info
RUN_DEPENDS+= update-mime-database:${PORTSDIR}/misc/shared-mime-info
# bolt our post-install target to post-install
+.PHONY: shared-mime-post-install
post-install: shared-mime-post-install
shared-mime-post-install:
diff --git a/Mk/Uses/shebangfix.mk b/Mk/Uses/shebangfix.mk
index e9108faf2e71..7e6caabb339d 100644
--- a/Mk/Uses/shebangfix.mk
+++ b/Mk/Uses/shebangfix.mk
@@ -48,6 +48,7 @@ IGNORE+= missing definition for ${lang}_OLD_CMD
_SHEBANG_REINPLACE_ARGS+= -e "1s|^\#![[:space:]]*${${lang}_OLD_CMD}|\#!${${lang}_CMD}|"
.endfor
+.PHONY: fix-shebang
pre-patch: fix-shebang
fix-shebang:
diff --git a/Mk/Uses/webplugin.mk b/Mk/Uses/webplugin.mk
index aec6c11b8797..52669970b0fe 100644
--- a/Mk/Uses/webplugin.mk
+++ b/Mk/Uses/webplugin.mk
@@ -166,6 +166,7 @@ WEBPLUGIN_DIR?= ${_WEBPLUGIN_LIBDIR:S,^${LOCALBASE}/,${PREFIX}/,}/${WEBPLUGIN_N
PLIST_SUB+= WEBPLUGIN_DIR="${WEBPLUGIN_DIR:S,^${PREFIX}/,,}"
+.PHONY: webplugin-post-install
webplugin-post-install:
@${ECHO_CMD} "@cwd ${LOCALBASE}" >> ${TMPPLIST}
.for d in ${_WEBPLUGIN_LINKFARMS}