aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorTorsten Zuehlsdorff <tz@FreeBSD.org>2017-11-16 10:48:48 +0000
committerTorsten Zuehlsdorff <tz@FreeBSD.org>2017-11-16 10:48:48 +0000
commit687591dd75e7bc33dfeb597493d97e5baaf89f1d (patch)
treea2ff3d816b255016827738be132f8fc8bff8f5d9 /Mk
parentaac918473dab5c241575ef1faf6f91a1736df61d (diff)
Notes
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/php.mk10
-rw-r--r--Mk/bsd.default-versions.mk2
2 files changed, 8 insertions, 4 deletions
diff --git a/Mk/Uses/php.mk b/Mk/Uses/php.mk
index ce01a49b6a01..87a4233708f9 100644
--- a/Mk/Uses/php.mk
+++ b/Mk/Uses/php.mk
@@ -114,7 +114,10 @@ DEFAULT_PHP_VER?= ${PHP_DEFAULT:S/.//}
# When adding a version, please keep the comment in
# Mk/bsd.default-versions.mk in sync.
PHP_VER?= ${DEFAULT_PHP_VER}
-. if ${PHP_VER} == 71
+. if ${PHP_VER} == 72
+PHP_EXT_DIR= 20170718
+PHP_EXT_INC= pcre spl
+. elif ${PHP_VER} == 71
PHP_EXT_DIR= 20160303
PHP_EXT_INC= pcre spl
. elif ${PHP_VER} == 70
@@ -301,9 +304,10 @@ _USE_PHP_ALL= bcmath bitset bz2 calendar ctype curl dba dom \
_USE_PHP_VER56= ${_USE_PHP_ALL} mssql mysql sybase_ct
_USE_PHP_VER70= ${_USE_PHP_ALL}
_USE_PHP_VER71= ${_USE_PHP_ALL}
+_USE_PHP_VER72= ${_USE_PHP_ALL} sodium
bcmath_DEPENDS= math/php${PHP_VER}-bcmath
-. if ${PHP_VER} == 70 || ${PHP_VER} == 71
+. if ${PHP_VER} == 70 || ${PHP_VER} == 71 || ${PHP_VER} == 72
bitset_DEPENDS= math/pecl-bitset
. else
bitset_DEPENDS= math/pecl-bitset2
@@ -328,7 +332,7 @@ iconv_DEPENDS= converters/php${PHP_VER}-iconv
igbinary_DEPENDS= converters/pecl-igbinary
imap_DEPENDS= mail/php${PHP_VER}-imap
interbase_DEPENDS= databases/php${PHP_VER}-interbase
-. if ${PHP_VER} == 70 || ${PHP_VER} == 71
+. if ${PHP_VER} == 70 || ${PHP_VER} == 71 || ${PHP_VER} == 72
intl_DEPENDS= devel/php${PHP_VER}-intl
. else
intl_DEPENDS= devel/pecl-intl
diff --git a/Mk/bsd.default-versions.mk b/Mk/bsd.default-versions.mk
index e6c369403018..28fd89f88432 100644
--- a/Mk/bsd.default-versions.mk
+++ b/Mk/bsd.default-versions.mk
@@ -73,7 +73,7 @@ PERL5_DEFAULT:= ${_PERL5_FROM_BIN:R}
.endif
# Possible values: 9.2, 9.3, 9.4, 9.5, 9.6
PGSQL_DEFAULT?= 9.5
-# Possible values: 5.6, 7.0, 7.1
+# Possible values: 5.6, 7.0, 7.1, 7.2
PHP_DEFAULT?= 5.6
# Possible values: 2.7, 3.4, 3.5, 3.6
PYTHON_DEFAULT?= 2.7