aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2020-06-25 12:37:26 +0000
committerMathieu Arnold <mat@FreeBSD.org>2020-06-25 12:37:26 +0000
commit07bf3be580507ea3cc09f059f0bedd6d136124e1 (patch)
tree4c9530f5ec136d087549ce0594d1943a523b9d2a /Mk
parent0856284444ef61a8c2e0fdc5afe56643312bc8ec (diff)
downloadports-07bf3be580507ea3cc09f059f0bedd6d136124e1.tar.gz
ports-07bf3be580507ea3cc09f059f0bedd6d136124e1.zip
Make sure rc files are owned by root:wheel with a sensible mode.
PR: 246158 Reported by: Chad Jacob Milios Differential Revision: https://reviews.freebsd.org/D25295
Notes
Notes: svn path=/head/; revision=540386
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 5abbf8525c2a..a41b81319706 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -4574,7 +4574,7 @@ install-rc-script:
_prefix=${PREFIX}; \
[ "${PREFIX}" = "/usr" ] && _prefix="" ; \
${INSTALL_SCRIPT} ${WRKDIR}/$${i} ${STAGEDIR}$${_prefix}/etc/rc.d/$${i%.sh}; \
- ${ECHO_CMD} "$${_prefix}/etc/rc.d/$${i%.sh}" >> ${TMPPLIST}; \
+ ${ECHO_CMD} "@(root,wheel,0755) $${_prefix}/etc/rc.d/$${i%.sh}" >> ${TMPPLIST}; \
done
.endif
.endif