aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2014-03-03 16:50:32 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2014-03-03 16:50:32 +0000
commit4cd1e8830ecdea3996915303a7cdb1aaaec56ca8 (patch)
tree0facf8a13da71e87170cdfcf5902ed77d09cb72f /Mk
parent9110d8d5d340cf5fa7e7a59070603dd554e3959c (diff)
downloadports-4cd1e8830ecdea3996915303a7cdb1aaaec56ca8.tar.gz
ports-4cd1e8830ecdea3996915303a7cdb1aaaec56ca8.zip
Notes
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk13
-rw-r--r--Mk/bsd.qt.mk10
2 files changed, 15 insertions, 8 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 11ac2ba3f823..2464e83e0e5b 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -435,16 +435,21 @@ FreeBSD_MAINTAINER= portmgr@FreeBSD.org
# USE_WX - If set, this port uses the WxWidgets library and related
# components. See bsd.wx.mk for more details.
##
-# USE_KDE4 - A list of the KDE4 dependencies the port has (e.g.,
+# USE_KDE4 - A list of the KDE 4 dependencies the port has (e.g.,
# kdelibs, kdebase). Implies that the port needs KDE.
# Implies inclusion of bsd.kde4.mk. See bsd.kde4.mk
# for more details.
#
-# USE_QT4 - A list of the QT4 dependencies the port has (e.g,
+# USE_QT4 - A list of the Qt 4 dependencies the port has (e.g,
# corelib, webkit). Implies that the port needs Qt.
# Implies the inclusion of bsd.qt.mk. See bsd.qt.mk
# for more details.
#
+# USE_QT5 - A list of the Qt 5 dependencies the port has (e.g,
+# core, webkit). Implies that the port needs Qt.
+# Implies the inclusion of bsd.qt.mk. See bsd.qt.mk
+# for more details.
+#
# USE_LINUX - Set to yes to say the port needs the default linux base port.
# Set to value <X>, if the port needs emulators/linux_base-<X>.
# Implies appropriate settings for STRIP and STRIP_CMD.
@@ -1440,7 +1445,7 @@ PKGCOMPATDIR?= ${LOCALBASE}/lib/compat/pkg
.include "${PORTSDIR}/Mk/bsd.apache.mk"
.endif
-.if defined(USE_QT4)
+.if defined(USE_QT4) || defined(USE_QT5)
.include "${PORTSDIR}/Mk/bsd.qt.mk"
.endif
@@ -1871,7 +1876,7 @@ IGNORE= Do not define STAGEDIR in command line
.include "${PORTSDIR}/Mk/bsd.linux-apps.mk"
.endif
-.if defined(USE_QT4)
+.if defined(USE_QT4) || defined(USE_QT5)
.include "${PORTSDIR}/Mk/bsd.qt.mk"
.endif
diff --git a/Mk/bsd.qt.mk b/Mk/bsd.qt.mk
index 306d9bd41aff..f13bb508ee88 100644
--- a/Mk/bsd.qt.mk
+++ b/Mk/bsd.qt.mk
@@ -27,7 +27,7 @@ Qt_Pre_Include= bsd.qt.mk
# Qt versions currently supported by the framework.
_QT_SUPPORTED?= 4 5
QT4_VERSION?= 4.8.5
-QT5_VERSION?= 5.2.0-beta1
+QT5_VERSION?= 5.2.1
QT_PREFIX?= ${LOCALBASE}
@@ -60,7 +60,6 @@ MASTER_SITES= ${MASTER_SITE_QT}
# Useless, as it must be defined before including bsd.port.pre.mk (at least
# because of bsd.options.mk).
#PKGNAMEPREFIX?= ${_QT_RELNAME}-
-DIST_SUBDIR= KDE
DISTINFO_FILE= ${.CURDIR:H:H}/devel/${_QT_RELNAME}/distinfo
# Can go after a while.
@@ -78,6 +77,7 @@ DESTDIRNAME= INSTALL_ROOT
. if ${_QT_VERSION:M4*}
MASTER_SITE_SUBDIR= official_releases/qt/${_QT_VERSION:R}/${_QT_VERSION}/
DISTNAME= qt-everywhere-opensource-src-${_QT_VERSION}
+DIST_SUBDIR= KDE
. else
. if ${_QT_VERSION:M*-*}
# Pre-releases.
@@ -87,6 +87,7 @@ MASTER_SITE_SUBDIR= official_releases/qt/${_QT_VERSION:R}/${_QT_VERSION}/submodu
. endif
DISTNAME= ${QT_DIST:S,^,qt,:S,$,-opensource-src-${_QT_VERSION},}
DISTFILES= ${DISTNAME:S,$,${EXTRACT_SUFX},}
+DIST_SUBDIR= KDE/Qt/${_QT_VERSION}
USE_XZ= yes
. if ${.TARGETS:Mmakesum} || ${.TARGETS:Mfetch} && \
@@ -551,8 +552,9 @@ _QT_TOOLS+= ${UIC}
pre-configure: qtbase-pre-configure
qtbase-pre-configure:
. if ${PORTNAME} != "qmake"
- @${RM} -rf ${CONFIGURE_WRKSRC}/mkspecs
- @${MKDIR} ${CONFIGURE_WRKSRC}/mkspecs
+ @(cd ${WRKSRC} && ${SETENV} ${QMAKE_ENV} ${QMAKE} ${QMAKE_ARGS})
+# @${RM} -rf ${CONFIGURE_WRKSRC}/mkspecs
+# @${MKDIR} ${CONFIGURE_WRKSRC}/mkspecs
. endif
. for tool in ${_QT_TOOLS}
@${TEST} -e ${QT_BINDIR}/${tool:T} && \