aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorFlorent Thoumie <flz@FreeBSD.org>2007-09-13 19:45:08 +0000
committerFlorent Thoumie <flz@FreeBSD.org>2007-09-13 19:45:08 +0000
commit62df320cc3d1faf415675ee470a2b6338548e00b (patch)
tree6eb76e71941e2aad2fb558ec0436f85cf000c6f5 /Mk
parent87cca574fd7f379db0710c925eab655b62046077 (diff)
downloadports-62df320cc3d1faf415675ee470a2b6338548e00b.tar.gz
ports-62df320cc3d1faf415675ee470a2b6338548e00b.zip
Notes
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk6
-rw-r--r--Mk/bsd.xorg.mk3
2 files changed, 8 insertions, 1 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index ef168d49f82e..ab08c18fe18b 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1940,6 +1940,12 @@ BUILD_DEPENDS+= bison:${PORTSDIR}/devel/bison
.include "${PORTSDIR}/Mk/bsd.local.mk"
.endif
+.if defined(USE_XORG) || defined(XORG_CAT)
+. if ${X_WINDOW_SYSTEM} == "xorg"
+.include "${PORTSDIR}/Mk/bsd.xorg.mk"
+. endif
+.endif
+
.if defined(USE_MYSQL) || defined(WANT_MYSQL_VER) || \
defined(USE_PGSQL) || defined(WANT_PGSQL_VER) || \
defined(USE_BDB) || defined(USE_SQLITE) || defined(USE_FIREBIRD)
diff --git a/Mk/bsd.xorg.mk b/Mk/bsd.xorg.mk
index eda8cb0c063d..dce9a5785050 100644
--- a/Mk/bsd.xorg.mk
+++ b/Mk/bsd.xorg.mk
@@ -149,7 +149,7 @@ USE_GNOME+= pkgconfig
# Register all xorg .pc files here.
# foo_LIB_PC_DEPENDS means it should go to BUILD_DEPENDS *and* RUN_DEPENDS.
-XORG_MODULES= bigreqsproto compositeproto damageproto dmx dmxproto evieproto fixesproto fontcacheproto fontenc fontsproto fontutil glproto ice inputproto kbproto libfs oldx printproto randrproto recordproto renderproto resourceproto scrnsaverproto sm trapproto videoproto x11 xau xaw xaw6 xaw7 xaw8 xbitmaps xcmiscproto xcomposite xcursor xdamage xdmcp xevie xext xextproto xf86bigfontproto xf86dgaproto xf86driproto xf86miscproto xf86rushproto xf86vidmodeproto xfixes xfont xfontcache xft xi xinerama xineramaproto xkbfile xkbui xmu xmuu xorg-server xp xpm xprintapputil xprintutil xproto xproxymngproto xrandr xrender xres xscrnsaver xt xtrans xtrap xtst xv xvmc xxf86dga xxf86misc xxf86vm
+XORG_MODULES= bigreqsproto compositeproto damageproto dmx dmxproto evieproto fixesproto fontcacheproto fontenc fontsproto fontutil glproto ice inputproto kbproto libfs oldx pixman printproto randrproto recordproto renderproto resourceproto scrnsaverproto sm trapproto videoproto x11 xau xaw xaw6 xaw7 xaw8 xbitmaps xcmiscproto xcomposite xcursor xdamage xdmcp xevie xext xextproto xf86bigfontproto xf86dgaproto xf86driproto xf86miscproto xf86rushproto xf86vidmodeproto xfixes xfont xfontcache xft xi xinerama xineramaproto xkbfile xkbui xmu xmuu xorg-server xp xpm xprintapputil xprintutil xproto xproxymngproto xrandr xrender xres xscrnsaver xt xtrans xtrap xtst xv xvmc xxf86dga xxf86misc xxf86vm
bigreqsproto_BUILD_DEPENDS= ${X11BASE}/libdata/pkgconfig/bigreqsproto.pc:${PORTSDIR}/x11/bigreqsproto
compositeproto_BUILD_DEPENDS= ${X11BASE}/libdata/pkgconfig/compositeproto.pc:${PORTSDIR}/x11/compositeproto
@@ -168,6 +168,7 @@ inputproto_BUILD_DEPENDS= ${X11BASE}/libdata/pkgconfig/inputproto.pc:${PORTSDIR}
kbproto_BUILD_DEPENDS= ${X11BASE}/libdata/pkgconfig/kbproto.pc:${PORTSDIR}/x11/kbproto
libfs_LIB_PC_DEPENDS= ${X11BASE}/libdata/pkgconfig/libfs.pc:${PORTSDIR}/x11-fonts/libFS
oldx_LIB_PC_DEPENDS= ${X11BASE}/libdata/pkgconfig/oldx.pc:${PORTSDIR}/x11/liboldX
+pixman_LIB_PC_DEPENDS= ${X11BASE}/libdata/pkgconfig/pixman-1.pc:${PORTSDIR}/x11/pixman
printproto_BUILD_DEPENDS= ${X11BASE}/libdata/pkgconfig/printproto.pc:${PORTSDIR}/x11/printproto
randrproto_BUILD_DEPENDS= ${X11BASE}/libdata/pkgconfig/randrproto.pc:${PORTSDIR}/x11/randrproto
recordproto_BUILD_DEPENDS= ${X11BASE}/libdata/pkgconfig/recordproto.pc:${PORTSDIR}/x11/recordproto