aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-08-17 09:11:08 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-08-17 09:11:08 +0000
commit642bf72f2742aca6846abd7b1b794f6e6228d785 (patch)
tree16b60ab8fc707c56fd010a1332dd069eb8d17ae4 /Mk
parentebdae4c240c2d48dec79872f8a8899fd6f1730b0 (diff)
Notes
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index e4e3b70cddc0..7c5bebf3e249 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1611,9 +1611,11 @@ PLIST_SUB_SED_tmp1= ${PLIST_SUB:C/.*=.{1,${PLIST_SUB_SED_MIN}}$//g}
# Remove empty values
# Remove @comment values
PLIST_SUB_SED_tmp2= ${PLIST_SUB_tmp1:NEXTRACT_SUFX=*:NOSREL=*:NLIB32DIR=*:NPREFIX=*:NLOCALBASE=*:NRESETPREFIX=*:N*="":N*="@comment*}
+# Handle VARS for which there is a _regex entry
+PLIST_SUB_SED_tmp3?= ${PLIST_SUB_SED_tmp1:C/(${PLIST_SUB:M*_regex=*:C/_regex=.*/=.*/:Q:S/\\ /|/g:S/\\//g})//:C/(.*)_regex=(.*)/\1=\2/}
# Remove quotes
# Replace . with \. for later sed(1) usage
-PLIST_SUB_SED?= ${PLIST_SUB_SED_tmp2:C/([^=]*)="?([^"]*)"?/s!\2!%%\1%%!g;/g:C/\./\\./g}
+PLIST_SUB_SED?= ${PLIST_SUB_SED_tmp3:C/([^=]*)="?([^"]*)"?/s!\2!%%\1%%!g;/g:C/\./\\./g}
# kludge to strip trailing whitespace from CFLAGS;
# sub-configure will not # survive double space