aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2009-09-12 18:07:51 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2009-09-12 18:07:51 +0000
commit6919a81f8158d7b4c92cffa656b33b151f0e9344 (patch)
treee2216995d05431fff5d29b0bebc970e9fd47f452 /Mk
parent5f0e7d0c20042ed15a8c9536d552a0d4effb4f5d (diff)
downloadports-6919a81f8158d7b4c92cffa656b33b151f0e9344.tar.gz
ports-6919a81f8158d7b4c92cffa656b33b151f0e9344.zip
Notes
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.gcc.mk16
1 files changed, 8 insertions, 8 deletions
diff --git a/Mk/bsd.gcc.mk b/Mk/bsd.gcc.mk
index 4e8af8a8b01d..779c5fdfa889 100644
--- a/Mk/bsd.gcc.mk
+++ b/Mk/bsd.gcc.mk
@@ -19,7 +19,7 @@
# If your port needs a Fortran compiler, please specify that with the
# USE_FORTRAN= knob. Here is the list of options for that knob:
#
-# USE_FORTRAN= yes # use gfortran43 (lang/gcc43)
+# USE_FORTRAN= yes # use gfortran44 (lang/gcc44)
# USE_FORTRAN= g77 # use g77-34 (lang/gcc34; FreeBSD>=7)
# # or system f77 (/usr/bin/f77; FreeBSD<=6)
# USE_FORTRAN= ifort # use the Intel compiler (lang/ifc)
@@ -64,14 +64,14 @@ GCCVERSION_040400= 999999 999999 4.4
.if defined (USE_FORTRAN)
-# gfortran43 from lang/gcc43 is the default for now.
+# The default case, with a current lang/gcc port.
. if ${USE_FORTRAN} == yes
-BUILD_DEPENDS+= gfortran43:${PORTSDIR}/lang/gcc43
-RUN_DEPENDS+= gfortran43:${PORTSDIR}/lang/gcc43
-FC:= gfortran43
-F77:= gfortran43
-CC:= gcc43
-CXX:= g++43
+BUILD_DEPENDS+= gfortran44:${PORTSDIR}/lang/gcc44
+RUN_DEPENDS+= gfortran44:${PORTSDIR}/lang/gcc44
+FC:= gfortran44
+F77:= gfortran44
+CC:= gcc44
+CXX:= g++44
# Intel Fortran compiler from lang/ifc.
. elif ${USE_FORTRAN} == ifort