aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2015-08-24 13:07:31 +0000
committerMathieu Arnold <mat@FreeBSD.org>2015-08-24 13:07:31 +0000
commit741e1ac05870d345e0f33abc25a00651983fc2b5 (patch)
tree9eeb316114df35c2875cb138b5084c240bd95740 /Mk
parent95412602bed0e7edf626f9d65f0ad0154643fdc1 (diff)
downloadports-741e1ac05870d345e0f33abc25a00651983fc2b5.tar.gz
ports-741e1ac05870d345e0f33abc25a00651983fc2b5.zip
Notes
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.options.mk2
-rw-r--r--Mk/bsd.port.mk3
2 files changed, 5 insertions, 0 deletions
diff --git a/Mk/bsd.options.mk b/Mk/bsd.options.mk
index 1a4f111b4c6f..22ec6a6562a1 100644
--- a/Mk/bsd.options.mk
+++ b/Mk/bsd.options.mk
@@ -100,6 +100,8 @@
# get enabled too.
# ${opt}_PREVENTS When opt is enabled, if any options in PREVENTS are
# also enabled, it will produce an error.
+# ${opt}_PREVENTS_MSG Provides a message explaining why the options
+# cannot be selected together.
#
# ${opt}_USE= FOO=bar When option is enabled, it will enable
# USE_FOO+= bar
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index bfcc02fd8ce9..3a1047578d00 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -5049,6 +5049,9 @@ _check-config: pre-check-config
@${ECHO_MSG} "====> Two or more enabled options conflict with each other"
. for prevents in ${OPTIONS_WRONG_PREVENTS}
@${ECHO_MSG} "=====> Option ${prevents} conflicts with ${OPTIONS_WRONG_PREVENTS_${prevents}} (select only one)"
+. if defined(${prevents}_PREVENTS_MSG)
+ @${ECHO_MSG} "======> ${${prevents}_PREVENTS_MSG}"
+. endif
. endfor
.endif
.if !empty(OPTIONS_WRONG_MULTI) || !empty(OPTIONS_WRONG_SINGLE) || !empty(OPTIONS_WRONG_RADIO) || !empty(OPTIONS_WRONG_PREVENTS)