aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2020-04-26 14:20:35 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2020-04-26 14:20:35 +0000
commit76906e8e9cc12ccfd42f9da6b36839c3b29b9a2b (patch)
tree1d52cced787359624f6d4c6b0d987fffe7851aed /Mk
parent00c723e559e4c0cebe4e6746ac8f77769964f7d8 (diff)
downloadports-76906e8e9cc12ccfd42f9da6b36839c3b29b9a2b.tar.gz
ports-76906e8e9cc12ccfd42f9da6b36839c3b29b9a2b.zip
Add support for GCC 10. That is in the release phase and has not seen
an upstream release yet, so we need to leverage the gcc10-devel port which we'll replace by gcc10 once that exists. This is not intended for production use, but to allow for an -exp run and preparing other ports.
Notes
Notes: svn path=/head/; revision=533066
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.gcc.mk6
1 files changed, 5 insertions, 1 deletions
diff --git a/Mk/bsd.gcc.mk b/Mk/bsd.gcc.mk
index 276aa744e961..f09a050cafce 100644
--- a/Mk/bsd.gcc.mk
+++ b/Mk/bsd.gcc.mk
@@ -34,7 +34,7 @@ GCC_Include_MAINTAINER= gerald@FreeBSD.org
# All GCC versions supported by the ports framework. Keep them in
# ascending order and in sync with the table below.
# When updating this, keep Mk/bsd.default-versions.mk in sync.
-GCCVERSIONS= 4.8 7 8 9
+GCCVERSIONS= 4.8 7 8 9 10
# No configurable parts below this. ####################################
#
@@ -89,7 +89,11 @@ _USE_GCC:= ${GCC_DEFAULT}
# A concrete version has been selected. Set proper ports dependencies,
# CC, CXX, CPP, and flags.
V:= ${_USE_GCC:S/.//}
+. if ${V} == 10
+_GCC_PORT:= gcc${V}-devel
+. else
_GCC_PORT:= gcc${V}
+. endif
CC:= gcc${V}
CXX:= g++${V}
CPP:= cpp${V}