aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2010-09-15 18:35:24 +0000
committerAde Lovett <ade@FreeBSD.org>2010-09-15 18:35:24 +0000
commit8262a7b51d413e11ef8f67c56e862ebbc6f182de (patch)
tree1e9812bc2638933184cae2b226809eb69253bb9f /Mk
parentbe8126109fa13097c8a0f9337fa9dfb68cf5d4c2 (diff)
Autotools update. Read ports/UPDATING 20100915 for details.
Approved by: portmgr (for Mk/bsd.port.mk part) Tested by: Multiple -exp runs
Notes
Notes: svn path=/head/; revision=261230
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.php.mk2
-rw-r--r--Mk/bsd.port.mk13
-rw-r--r--Mk/bsd.ruby.mk2
3 files changed, 12 insertions, 5 deletions
diff --git a/Mk/bsd.php.mk b/Mk/bsd.php.mk
index b599134c9de4..c7360cc5315d 100644
--- a/Mk/bsd.php.mk
+++ b/Mk/bsd.php.mk
@@ -157,7 +157,7 @@ SUB_LIST+= PHP_EXT_DIR=${PHP_EXT_DIR}
.if defined(USE_PHPIZE) || defined(USE_PHPEXT)
BUILD_DEPENDS+= ${PHPBASE}/bin/phpize:${PORTSDIR}/${PHP_PORT}
GNU_CONFIGURE= yes
-USE_AUTOTOOLS+= autoconf:262:env
+USE_AUTOTOOLS+= autoconf:267:env
CONFIGURE_ARGS+=--with-php-config=${PHPBASE}/bin/php-config
configure-message: phpize-message do-phpize
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index ffd0233a5442..c51b18177be2 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -318,7 +318,10 @@ FreeBSD_MAINTAINER= portmgr@FreeBSD.org
# Default: gmake
##
# USE_ICONV - If set, this port uses libiconv.
-# USE_GETTEXT - If set, this port uses GNU gettext (libintl).
+# USE_GETTEXT - The port uses GNU gettext (libintl).
+# 'build' as a build-time dependency
+# 'yes' as a library dependency
+# 'run' as a run-time dependency
##
# USE_PERL5 - If set, this port uses perl5 in one or more of the extract,
# patch, build, install or run phases.
@@ -1892,10 +1895,14 @@ LIB_DEPENDS+= iconv.3:${PORTSDIR}/converters/libiconv
.endif
.if defined(USE_GETTEXT)
-. if ${USE_GETTEXT:L} == "yes"
+. if ${USE_GETTEXT:L} == "build"
+BUILD_DEPENDS+= xgettext:${PORTSDIR}/devel/gettext
+. elif ${USE_GETTEXT:L} == "run"
+RUN_DEPENDS+= xgettext:${PORTSDIR}/devel/gettext
+. elif ${USE_GETTEXT:L} == "yes"
LIB_DEPENDS+= intl:${PORTSDIR}/devel/gettext
. else
-LIB_DEPENDS+= intl.${USE_GETTEXT}:${PORTSDIR}/devel/gettext
+IGNORE= USE_GETTEXT can be only one of build, run, or yes
. endif
.endif
diff --git a/Mk/bsd.ruby.mk b/Mk/bsd.ruby.mk
index 5e15c0c9ed35..c79dc4486c6e 100644
--- a/Mk/bsd.ruby.mk
+++ b/Mk/bsd.ruby.mk
@@ -171,7 +171,7 @@ RUBY?= ${LOCALBASE}/bin/${RUBY_NAME}
# Ruby 1.8
#
RUBY_RELVERSION= 1.8.7
-RUBY_PORTREVISION= 3
+RUBY_PORTREVISION= 4
RUBY_PORTEPOCH= 1
RUBY_PATCHLEVEL= 248