aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2020-04-29 14:01:05 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2020-04-29 14:01:05 +0000
commit86dce8416ee140ad9930122c4bee22078858a8ff (patch)
treeb4b300b42df89e8029748592a549e33e06af794a /Mk
parenta6560981d4d9e11e241ccd4b2c514f19e254cc08 (diff)
downloadports-86dce8416ee140ad9930122c4bee22078858a8ff.tar.gz
ports-86dce8416ee140ad9930122c4bee22078858a8ff.zip
Allow lua scripts in the framworks.
Bump the minimum required pkg version to a version that accepts properly lua scripts Lua script offers the advantages over shell scripts that they are running in a capsicum sandbox and they are natively rootdir friendly Reviewed by: portmgr (mat) Differential Revision: https://reviews.freebsd.org/D21433
Notes
Notes: svn path=/head/; revision=533337
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Scripts/create-manifest.sh1
-rw-r--r--Mk/bsd.port.mk2
2 files changed, 2 insertions, 1 deletions
diff --git a/Mk/Scripts/create-manifest.sh b/Mk/Scripts/create-manifest.sh
index e94d637b1bbe..cb924a03839c 100644
--- a/Mk/Scripts/create-manifest.sh
+++ b/Mk/Scripts/create-manifest.sh
@@ -104,6 +104,7 @@ for stage in INSTALL DEINSTALL UPGRADE; do
output=${dp_METADIR}/+${prepost:+${prepost}_}${stage}
for input in ${files}; do
[ -f "${input}" ] && cat ${input} >> ${output}
+ [ -f "${input}.lua" ] && cp ${input}.lua ${dp_METADIR}
done
done
done
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index c4730b778029..116015aeb3be 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1047,7 +1047,7 @@ _FLAVOR:= ${FLAVOR}
.if !defined(PORTS_FEATURES) && empty(${PORTS_FEATURES:MFLAVORS})
PORTS_FEATURES+= FLAVORS
.endif
-MINIMAL_PKG_VERSION= 1.6.0
+MINIMAL_PKG_VERSION= 1.13.0
_PORTS_DIRECTORIES+= ${PKG_DBDIR} ${PREFIX} ${WRKDIR} ${EXTRACT_WRKDIR} \
${STAGEDIR}${PREFIX} ${WRKDIR}/pkg ${BINARY_LINKDIR}