aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2020-06-04 18:08:00 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2020-06-04 18:08:00 +0000
commita48473296fd3a4eb1254580675e395de5e3a8c96 (patch)
tree742c56dce41eeb42924653ac0fe8cd1e99bc515e /Mk
parent4ac6b2da9882a3ba00172dfd7646ee3b0c077ba7 (diff)
downloadports-a48473296fd3a4eb1254580675e395de5e3a8c96.tar.gz
ports-a48473296fd3a4eb1254580675e395de5e3a8c96.zip
lang/rust: Update to 1.44.0
- Remove devel/cargo-tree since it is now integrated into cargo - Add patch to fix build with LibreSSL 3.1.x and 3.2.0 [1] - Force rebuild all consumers to catch regressions early Changes: https://blog.rust-lang.org/2020/06/04/Rust-1.44.0.html PR: 246332 [1] Tested by: mikael, tobik With hat: rust Differential Revision: https://reviews.freebsd.org/D25099
Notes
Notes: svn path=/head/; revision=537917
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/cargo.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/Mk/Uses/cargo.mk b/Mk/Uses/cargo.mk
index d471383fae95..46fd8b2c4cbe 100644
--- a/Mk/Uses/cargo.mk
+++ b/Mk/Uses/cargo.mk
@@ -45,7 +45,7 @@ DISTFILES+= ${CARGO_DIST_SUBDIR}/${_crate}.tar.gz:cargo_${_crate:C/[^a-zA-Z0-9_]
CARGO_BUILDDEP?= yes
.if ${CARGO_BUILDDEP:tl} == "yes"
-BUILD_DEPENDS+= ${RUST_DEFAULT}>=1.43.0:lang/${RUST_DEFAULT}
+BUILD_DEPENDS+= ${RUST_DEFAULT}>=1.44.0:lang/${RUST_DEFAULT}
.endif
# Location of cargo binary (default to lang/rust's Cargo binary)