aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2013-06-09 16:02:03 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2013-06-09 16:02:03 +0000
commita96308c51e5f50217cdade95d43560d064259e2b (patch)
tree240533a93bd89c68657597316dd8d52a870f43e0 /Mk
parent6bc83b9a9ba0b5c86062f0ebcd967f061bb93d39 (diff)
downloadports-a96308c51e5f50217cdade95d43560d064259e2b.tar.gz
ports-a96308c51e5f50217cdade95d43560d064259e2b.zip
Notes
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.options.mk11
1 files changed, 2 insertions, 9 deletions
diff --git a/Mk/bsd.options.mk b/Mk/bsd.options.mk
index dfe42536f913..3d1010f1c0be 100644
--- a/Mk/bsd.options.mk
+++ b/Mk/bsd.options.mk
@@ -73,9 +73,6 @@ PORT_OPTIONS+= EXAMPLES
# Activate IPV6 by default
PORT_OPTIONS+= IPV6
-# Exclude per arch options
-_ALL_EXCLUDE= ${OPTIONS_EXCLUDE_${ARCH}} ${OPTIONS_EXCLUDE} ${OPTIONS_SLAVE}
-
# Add per arch options
.for opt in ${OPTIONS_DEFINE_${ARCH}}
.if empty(OPTIONS_DEFINE:M${opt})
@@ -98,15 +95,11 @@ ALL_OPTIONS+= ${opt}
ALL_OPTIONS:= ${ALL_OPTIONS:O:u}
OPTIONS_DEFAULT:= ${OPTIONS_DEFAULT:O:u}
-# Remove global options the port maintainer doesn't want
-.for opt in ${_ALL_EXCLUDE}
+# Remove options the port maintainer doesn't want
+.for opt in ${OPTIONS_EXCLUDE_${ARCH}} ${OPTIONS_EXCLUDE} ${OPTIONS_SLAVE}
OPTIONS_DEFAULT:= ${OPTIONS_DEFAULT:N${opt}}
ALL_OPTIONS:= ${ALL_OPTIONS:N${opt}}
PORT_OPTIONS:= ${PORT_OPTIONS:N${opt}}
-.endfor
-
-# Remove illegal per-arch options
-.for opt in ${_ALL_EXCLUDE}
. for single in ${OPTIONS_SINGLE}
OPTIONS_SINGLE_${single}:= ${OPTIONS_SINGLE_${single}:N${opt}}
. endfor