aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2020-06-02 08:49:21 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2020-06-02 08:49:21 +0000
commitd610ef4216ba81fbd910389504a9d77b8bf8f782 (patch)
treec89b81d6068b101c704eed7626a8e189d9febb82 /Mk
parent2fedb62aea988a6ba0b0e96d9bf61a97002218b6 (diff)
downloadports-d610ef4216ba81fbd910389504a9d77b8bf8f782.tar.gz
ports-d610ef4216ba81fbd910389504a9d77b8bf8f782.zip
Now that GCC 10.1 has been released and lang/gcc10 arrived to track
GCC 10 releases, switch to that over lang/gcc10-devel when GCC 10 is requested. Use lang/gcc11-devel when GCC 11 is requested, but note that this is absolutely experimental and subject to constant change and likely breakage over the next half year at least before that release series enters stabilization. Use at your own risk.
Notes
Notes: svn path=/head/; revision=537529
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.gcc.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/Mk/bsd.gcc.mk b/Mk/bsd.gcc.mk
index f09a050cafce..b315b8671b75 100644
--- a/Mk/bsd.gcc.mk
+++ b/Mk/bsd.gcc.mk
@@ -34,7 +34,7 @@ GCC_Include_MAINTAINER= gerald@FreeBSD.org
# All GCC versions supported by the ports framework. Keep them in
# ascending order and in sync with the table below.
# When updating this, keep Mk/bsd.default-versions.mk in sync.
-GCCVERSIONS= 4.8 7 8 9 10
+GCCVERSIONS= 4.8 7 8 9 10 11
# No configurable parts below this. ####################################
#
@@ -89,7 +89,7 @@ _USE_GCC:= ${GCC_DEFAULT}
# A concrete version has been selected. Set proper ports dependencies,
# CC, CXX, CPP, and flags.
V:= ${_USE_GCC:S/.//}
-. if ${V} == 10
+. if ${V} == 11
_GCC_PORT:= gcc${V}-devel
. else
_GCC_PORT:= gcc${V}