aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>2001-09-28 16:45:15 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>2001-09-28 16:45:15 +0000
commite565d118b24ccabcd013a0753aabe64cb92d69dc (patch)
tree5a1b111d54bb4f28eabeac4b38a99ab16826b98a /Mk
parentb730a1b205f6c5faabeb8766438bbdaa3609c720 (diff)
Notes
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk5
1 files changed, 4 insertions, 1 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index d003b1d4b67d..dd4cfd440097 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -457,6 +457,8 @@ FreeBSD_MAINTAINER= portmgr@FreeBSD.org
# NO_LATEST_LINK - Do not install the "Latest" link for package. Define this
# if this port is a beta version of another stable port
# which is also in the tree.
+# LATEST_LINK - Install the "Latest" link for the package as ___. Define
+# this if the "Latest" link name will be incorrectly determined.
#
# This is used in all stages:
#
@@ -1265,7 +1267,8 @@ PKGFILE?= ${.CURDIR}/${PKGNAME}${PKG_SUFX}
# The "latest version" link -- ${PKGNAME} minus everthing after the last '-'
PKGLATESTREPOSITORY?= ${PACKAGES}/Latest
PKGBASE?= ${PKGNAMEPREFIX}${PORTNAME}${PKGNAMESUFFIX}
-PKGLATESTFILE?= ${PKGLATESTREPOSITORY}/${PKGBASE}${PKG_SUFX}
+LATEST_LINK?= ${PKGBASE}
+PKGLATESTFILE= ${PKGLATESTREPOSITORY}/${LATEST_LINK}${PKG_SUFX}
.if defined(PERL_CONFIGURE)
CONFIGURE_ARGS+= CC="${CC}" CCFLAGS="${CFLAGS}" PREFIX="${PREFIX}"