aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2013-09-04 16:54:39 +0000
committerAndrej Zverev <az@FreeBSD.org>2013-09-04 16:54:39 +0000
commit28a6974148655b55f3da429c780bb1ad30442871 (patch)
tree9ed0a39c2342bb438cc4778013b61fa8bcce72ba /Mk
parentf4ecd3423a92a336e90f3d636790050805f8c7ab (diff)
downloadports-28a6974148655b55f3da429c780bb1ad30442871.tar.gz
ports-28a6974148655b55f3da429c780bb1ad30442871.zip
Notes
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/perl5.mk8
1 files changed, 6 insertions, 2 deletions
diff --git a/Mk/Uses/perl5.mk b/Mk/Uses/perl5.mk
index 260cb489f339..0024e4811294 100644
--- a/Mk/Uses/perl5.mk
+++ b/Mk/Uses/perl5.mk
@@ -153,12 +153,16 @@ _MANPAGES+= ${P5MAN${sect}:S%^%${PREFIX}/lib/perl5/${PERL_VER}/man/man${sect}/%}
.if ${_USE_PERL5:Mmodbuild} || ${_USE_PERL5:Mmodbuildtiny}
_USE_PERL5+= configure
CONFIGURE_SCRIPT?= Build.PL
+.if ${_USE_PERL5:Mmodbuild}
.if ${PORTNAME} != Module-Build
BUILD_DEPENDS+= ${SITE_PERL}/Module/Build.pm:${PORTSDIR}/devel/p5-Module-Build
.endif
+.endif
.if ${_USE_PERL5:Mmodbuildtiny}
+.if ${PORTNAME} != Module-Build-Tiny
BUILD_DEPENDS+= ${SITE_PERL}/Module/Build/Tiny.pm:${PORTSDIR}/devel/p5-Module-Build-Tiny
.endif
+.endif
ALL_TARGET?=
PL_BUILD?= Build
CONFIGURE_ARGS+= \
@@ -216,14 +220,14 @@ do-configure:
@cd ${CONFIGURE_WRKSRC} && \
${SETENV} ${CONFIGURE_ENV} \
${PERL5} ./${CONFIGURE_SCRIPT} ${CONFIGURE_ARGS}
-.if !${_USE_PERL5:Mmodbuild}
+.if !${_USE_PERL5:Mmodbuild*}
@cd ${CONFIGURE_WRKSRC} && \
${PERL5} -pi -e 's/ doc_(perl|site|\$$\(INSTALLDIRS\))_install$$//' Makefile
.endif # ! modbuild
.endif # !target(do-configure)
.endif # configure
-.if ${_USE_PERL5:Mmodbuild}
+.if ${_USE_PERL5:Mmodbuild*}
.if !target(do-build)
do-build:
@(cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} ${PL_BUILD} ${MAKE_ARGS} ${ALL_TARGET})