aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-07-09 17:43:11 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-07-09 17:43:11 +0000
commit9e5632dd661f75b5801706e55659a4da501e49b5 (patch)
tree1a0770d8cc1771f94f7777b9a986bb87029c35d9 /Mk
parent90c653ebbfee158880bc5fc4eb15ad057288510a (diff)
downloadports-9e5632dd661f75b5801706e55659a4da501e49b5.tar.gz
ports-9e5632dd661f75b5801706e55659a4da501e49b5.zip
Notes
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.autotools.mk15
1 files changed, 14 insertions, 1 deletions
diff --git a/Mk/bsd.autotools.mk b/Mk/bsd.autotools.mk
index c0db71d4d128..e5d105c37cca 100644
--- a/Mk/bsd.autotools.mk
+++ b/Mk/bsd.autotools.mk
@@ -266,6 +266,9 @@ LIB_DEPENDS+= ltdl.4:${PORTSDIR}/devel/libltdl15
.if defined(USE_LIBTOOL_VER)
GNU_CONFIGURE?= yes
WANT_LIBTOOL_VER?= ${USE_LIBTOOL_VER}
+.elif defined(USE_INC_LIBTOOL_VER)
+GNU_CONFIGURE?= yes
+WANT_LIBTOOL_VER?= ${USE_INC_LIBTOOL_VER}
.endif
# Note that there aren't any non-versioned libtools, so we can skip
@@ -384,7 +387,7 @@ run-autotools:
#
.if !target(patch-autotools)
patch-autotools:
-. if defined(USE_LIBTOOL_VER)
+. if defined(USE_INC_LIBTOOL_VER)
@(cd ${PATCH_WRKSRC}; \
for file in ${LIBTOOLFILES}; do \
${CP} $$file $$file.tmp; \
@@ -393,6 +396,16 @@ patch-autotools:
$$file.tmp > $$file; \
${RM} $$file.tmp; \
done);
+. elif defined(USE_LIBTOOL_VER)
+ @(cd ${PATCH_WRKSRC}; \
+ for file in ${LIBTOOLFILES}; do \
+ ${CP} $$file $$file.tmp; \
+ ${SED} -e "s^\$$ac_aux_dir/ltconfig^${LTCONFIG}^g" \
+ -e "/^ltmain=/!s^\$$ac_aux_dir/ltmain.sh^${LIBTOOLFLAGS} ${LTMAIN}^g" \
+ -e '/^LIBTOOL=/s^\$$(top_builddir)/libtool^${LIBTOOL}^g' \
+ $$file.tmp > $$file; \
+ ${RM} $$file.tmp; \
+ done);
. else
@${DO_NADA}
. endif