aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorAlexander Botero-Lowry <alexbl@FreeBSD.org>2006-12-08 21:50:20 +0000
committerAlexander Botero-Lowry <alexbl@FreeBSD.org>2006-12-08 21:50:20 +0000
commitad1bbf18357af5fc7d4c96ded2bf2b26ebac1eed (patch)
treecd9e7a9e9746f7799fb5f57a1af21a4ad522acb1 /Mk
parent1c9dc5ef783bf7afe9d85a5cc8c3ab937fd28d83 (diff)
downloadports-ad1bbf18357af5fc7d4c96ded2bf2b26ebac1eed.tar.gz
ports-ad1bbf18357af5fc7d4c96ded2bf2b26ebac1eed.zip
Notes
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.python.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/Mk/bsd.python.mk b/Mk/bsd.python.mk
index 1e5e354fdd06..6c02eb096d7f 100644
--- a/Mk/bsd.python.mk
+++ b/Mk/bsd.python.mk
@@ -104,6 +104,12 @@ Python_Include_MAINTAINER= python@FreeBSD.org
# PYXML - Dependency line for the XML extension. As of Python-2.0,
# this extension is in the base distribution.
#
+# PYEXPAT - Dependency line for the Expat XML Parser. As of Python-2.3.2,
+# this module is in the base distribution.
+#
+# PYCTYPES - Dependency line for the ctypes package. As of Python-2.5,
+# this module is in the base distribution.
+#
# USE_PYTHON_PREFIX - Says that the port installs in ${PYTHONBASE}.
#
# USE_PYDISTUTILS - Use distutils as do-configure, do-build and do-install
@@ -429,6 +435,12 @@ PYEXPAT= ${PYTHON_SITELIBDIR}/pyexpat.so:${PORTSDIR}/textproc/py-expat
PYEXPAT= ${PYTHON_LIBDIR}/lib-dynload/pyexpat.so:${PYTHON_PORTSDIR}
.endif
+.if defined(PYTHON_REL) && ${PYTHON_REL} < 250
+PYCTYPES= ${PYTHON_SITELIBDIR}/ctypes/__init__.py:${PORTSDIR}/devel/py-ctypes
+.else
+PYCTYPES= ${PYTHON_LIBDIR}/ctypes/__init__py:${PYTHON_PORTSDIR}
+.endif
+
# dependencies
PYTHON_NO_DEPENDS?= NO