aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2007-04-05 13:52:44 +0000
committerPav Lucistnik <pav@FreeBSD.org>2007-04-05 13:52:44 +0000
commitc470893e3ecd75230d54d4e2e45e03d076aa0376 (patch)
treee7be31389608ab5a8239291f6f79f818913dbdbc /Mk
parent4a257f749646a22b73374e617926606c5da01ce0 (diff)
downloadports-c470893e3ecd75230d54d4e2e45e03d076aa0376.tar.gz
ports-c470893e3ecd75230d54d4e2e45e03d076aa0376.zip
Notes
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk8
1 files changed, 5 insertions, 3 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index a4c9df222112..915600beb18a 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -3304,7 +3304,7 @@ check-vulnerable:
# set alg to any of SIZE, MD5, SHA256 (or any other checksum algorithm):
DISTINFO_DATA?= DIR=${DIST_SUBDIR}; ${AWK} -v alg=$$alg \
- -v file=$${DIR:+$$DIR/}$${file\#\#*/} \
+ -v file=$${DIR:+$$DIR/}$${file} \
'$$1 == alg && $$2 == "(" file ")" {print $$4}' ${MD5_FILE}
# Fetch
@@ -4588,13 +4588,14 @@ checksum: fetch check-checksum-algorithms
cd ${DISTDIR}; OK="";\
for file in ${_CKSUMFILES}; do \
ignored="true"; \
+ _file=$${file#${DIST_SUBDIR}/*}; \
for alg in ${CHECKSUM_ALGORITHMS:U}; do \
ignore="false"; \
eval alg_executable=\$$$$alg; \
\
if [ $$alg_executable != "NO" ]; then \
MKSUM=`$$alg_executable < $$file`; \
- CKSUM=`${DISTINFO_DATA}`; \
+ CKSUM=`file=$$_file; ${DISTINFO_DATA}`; \
else \
ignore="true"; \
fi; \
@@ -4639,6 +4640,7 @@ checksum: fetch check-checksum-algorithms
done; \
\
for file in ${_IGNOREFILES}; do \
+ _file=$${file#${DIST_SUBDIR}/*}; \
ignored="true"; \
alreadymatched="false"; \
for alg in ${CHECKSUM_ALGORITHMS:U}; do \
@@ -4646,7 +4648,7 @@ checksum: fetch check-checksum-algorithms
eval alg_executable=\$$$$alg; \
\
if [ $$alg_executable != "NO" ]; then \
- CKSUM=`${DISTINFO_DATA}`; \
+ CKSUM=`file=$$_file; ${DISTINFO_DATA}`; \
else \
ignore="true"; \
fi; \