aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2006-04-29 23:03:03 +0000
committerMichael Johnson <ahze@FreeBSD.org>2006-04-29 23:03:03 +0000
commitd8e1e16e64701b6d51c9402ad779fd5560b8ce51 (patch)
tree266f139932061c245ade2aa3ef5c087c802dc5e3 /Mk
parent96ae3a6609c06c520d2aad7f2f89fb23d7b54e8e (diff)
downloadports-d8e1e16e64701b6d51c9402ad779fd5560b8ce51.tar.gz
ports-d8e1e16e64701b6d51c9402ad779fd5560b8ce51.zip
Notes
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.gstreamer.mk106
1 files changed, 63 insertions, 43 deletions
diff --git a/Mk/bsd.gstreamer.mk b/Mk/bsd.gstreamer.mk
index b8a37aca8de8..ed4928c6fbc6 100644
--- a/Mk/bsd.gstreamer.mk
+++ b/Mk/bsd.gstreamer.mk
@@ -7,7 +7,7 @@
# Date: 4 Oct 2004
#
# $FreeBSD$
-#
+# $MCom: ports/Mk/bsd.gstreamer.mk,v 1.24 2006/04/25 14:45:31 ahze Exp $
.if !defined(_POSTMKINCLUDED) && !defined(Gstreamer_Pre_Include)
@@ -18,7 +18,10 @@ Gstreamer_Pre_Include= bsd.gstreamer.mk
# Ports can use the following:
#
-# USE_GSTREAMER= dvd lame flac
+# For Gstreamer 0.10:
+# USE_GSTREAMER= lame faac ffmpeg
+# For Gstreamer 0.8:
+# USE_GSTREAMER80= dvd lame flac
#
# If you want to use USE_GSTREAMER after <bsd.port.pre.mk>
# you must follow one of the examples listed below
@@ -45,14 +48,25 @@ Gstreamer_Pre_Include= bsd.gstreamer.mk
#
GSTREAMER_PORT= ${PORTSDIR}/multimedia/gstreamer-plugins
+GSTREAMER80_PORT= ${GSTREAMER_PORT}80
_GST_LIB_BASE= ${X11BASE}/lib/gstreamer-${GST_VERSION}
-GST_VERSION= 0.8
+_GST80_LIB_BASE= ${X11BASE}/lib/gstreamer-${GST80_VERSION}
+GST_VERSION= 0.10
+GST_MINOR_VERSION= .0
+GST80_VERSION= 0.8
+GST80_MINOR_VERSION= .10
GST_SHLIB_VERSION= 1
-
+GST80_SHLIB_VERSION= 1
#
# These are the current supported gstreamer-plugins modules
#
-_USE_GSTREAMER_ALL= a52dec aalib artsd audiofile cairo cdaudio cdio cdparanoia \
+_USE_GSTREAMER_ALL= a52dec aalib bad cairo cdparanoia \
+ dv esound faac faad ffmpeg flac gconf gnomevfs \
+ gnonlin good gsm ivorbis jpeg ladspa lame libcaca \
+ libmms libpng libvisual mad mpeg2dec \
+ musepack ogg pango sdl shout2 sidplay \
+ speex theora ugly vorbis wavpack
+_USE_GSTREAMER80_ALL= a52dec aalib artsd audiofile cairo cdaudio cdio cdparanoia \
dirac dts dv dvd esound faac faad ffmpeg flac \
gconf gdkpixbuf gnomevfs gsm hermes ivorbis jack jpeg \
jpeg-mmx ladspa lame libcaca libfame libmms libmng \
@@ -60,29 +74,28 @@ _USE_GSTREAMER_ALL= a52dec aalib artsd audiofile cairo cdaudio cdio cdparanoia \
musepack musicbrainz nas sdl shout shout2 sidplay \
smoothwave sndfile speex theora ogg pango polyp \
swfdec vorbis wavpack x264 xvid
-
# other plugins
OTHER_GSTREAMER_PLUGINS+= core yes
+OTHER_GSTREAMER80_PLUGINS+= ${OTHER_GSTREAMER_PLUGINS}
+
_USE_GSTREAMER_ALL+= ${OTHER_GSTREAMER_PLUGINS}
+_USE_GSTREAMER80_ALL+= ${OTHER_GSTREAMER80_PLUGINS}
core_DEPENDS= multimedia/gstreamer-plugins-core
-core_PLIST= .gstreamer-plugins-core
-core_GST_EXT= .keep
yes_DEPENDS= multimedia/gstreamer-plugins
-yes_PLIST= libgstac3parse
+yes_NAME= gstreamer-plugins
+yes_GST80_PREFIX= # empty
+yes_GST_PREFIX= # empty
cdio_DEPENDS= sysutils/gstreamer-plugins-cdio
-cdio_PLIST= libgstcddasrc
gconf_DEPENDS= devel/gstreamer-plugins-gconf
-gconf_PLIST= libgstgconfelements
# Audio Plugins Section
a52dec_DEPENDS= audio/gstreamer-plugins-a52dec
artsd_DEPENDS= audio/gstreamer-plugins-artsd
-artsd_PLIST= libgstartsdsink
audiofile_DEPENDS= audio/gstreamer-plugins-audiofile
@@ -91,7 +104,6 @@ cdaudio_DEPENDS= audio/gstreamer-plugins-cdaudio
cdparanoia_DEPENDS= audio/gstreamer-plugins-cdparanoia
esound_DEPENDS= audio/gstreamer-plugins-esound
-esound_PLIST= libgstesd
faac_DEPENDS= audio/gstreamer-plugins-faac
@@ -116,22 +128,18 @@ mikmod_DEPENDS= audio/gstreamer-plugins-mikmod
musepack_DEPENDS= audio/gstreamer-plugins-musepack
musicbrainz_DEPENDS= audio/gstreamer-plugins-musicbrainz
-musicbrainz_PLIST= libgsttrm
nas_DEPENDS= audio/gstreamer-plugins-nas
-nas_PLIST= libgstnassink
ogg_DEPENDS= audio/gstreamer-plugins-ogg
polyp_DEPENDS= audio/gstreamer-plugins-polyp
-polyp_PLIST= libpolypaudio
shout_DEPENDS= audio/gstreamer-plugins-shout
shout2_DEPENDS= audio/gstreamer-plugins-shout2
sidplay_DEPENDS= audio/gstreamer-plugins-sidplay
-sidplay_PLIST= libgstsid
smoothwave_DEPENDS= audio/gstreamer-plugins-smoothwave
@@ -147,52 +155,52 @@ wavpack_DEPENDS= audio/gstreamer-plugins-wavpack
gnomevfs_DEPENDS= devel/gstreamer-plugins-gnomevfs
sdl_DEPENDS= devel/gstreamer-plugins-sdl
-sdl_PLIST= libgstsdlvideosink
# Graphics Plugins Section
aalib_DEPENDS= graphics/gstreamer-plugins-aalib
-aalib_PLIST= libgstaasink
cairo_DEPENDS= graphics/gstreamer-plugins-cairo
gdkpixbuf_DEPENDS= graphics/gstreamer-plugins-gdkpixbuf
hermes_DEPENDS= graphics/gstreamer-plugins-hermes
-hermes_PLIST= libgsthermescolorspace
jpeg_DEPENDS= graphics/gstreamer-plugins-jpeg
jpeg-mmx_DEPENDS= graphics/gstreamer-plugins-jpeg-mmx
-jpeg-mmx_PLIST= libgstjpeg
libcaca_DEPENDS= graphics/gstreamer-plugins-libcaca
-libcaca_PLIST= libgstcacasink
libmng_DEPENDS= graphics/gstreamer-plugins-libmng
-libmng_PLIST= libgstmng
libpng_DEPENDS= graphics/gstreamer-plugins-libpng
-libpng_PLIST= libgstpng
libvisual_DEPENDS= graphics/gstreamer-plugins-libvisual
swfdec_DEPENDS= graphics/gstreamer-plugins-swfdec
# Multimedia Plugins Section
+bad_DEPENDS= multimedia/gstreamer-plugins-bad
+
dirac_DEPENDS= multimedia/gstreamer-plugins-dirac
dts_DEPENDS= multimedia/gstreamer-plugins-dts
-dts_PLIST= libgstdtsdec
ffmpeg_DEPENDS= multimedia/gstreamer-ffmpeg
-
-libcaca_PLIST= libgstcacasink
+ffmpeg_GST80_SUFX= 80
+ffmpeg_GST80_PREFIX= gstreamer-
+ffmpeg_GST_PREFIX= gstreamer-
+ffmpeg_GST_SUFX= # empty
+ffmpeg_GST80_VERSION= 0.8.7
+ffmpeg_GST_VERSION= 0.10.0
dv_DEPENDS= multimedia/gstreamer-plugins-dv
-dv_PLIST= libgstdvdec
dvd_DEPENDS= multimedia/gstreamer-plugins-dvd
-dvd_PLIST= libgstdvdnavsrc
+
+good_DEPENDS= multimedia/gstreamer-plugins-good
+
+gnonlin_DEPENDS= multimedia/gstreamer-plugins-gnonlin
libfame_DEPENDS= multimedia/gstreamer-plugins-libfame
@@ -204,42 +212,54 @@ mplex_DEPENDS= multimedia/gstreamer-plugins-mplex
theora_DEPENDS= multimedia/gstreamer-plugins-theora
+ugly_DEPENDS= multimedia/gstreamer-plugins-ugly
+
x264_DEPENDS= multimedia/gstreamer-plugins-x264
-x264_PLIST= libx264
xvid_DEPENDS= multimedia/gstreamer-plugins-xvid
# Net Plugins Section
libmms_DEPENDS= net/gstreamer-plugins-libmms
-libmms_PLIST= libgstmms
# X11-Toolkits Plugins Section
pango_DEPENDS= x11-toolkits/gstreamer-plugins-pango
-pango_PLIST= libgsttextoverlay
.if defined(_POSTMKINCLUDED) && !defined(Gstreamer_Post_Include)
Gstreamer_Post_Include= bsd.gstreamer.mk
-# defined ext_PLIST="" for each port that uses auto plist
+.for ext in ${USE_GSTREAMER80}
+${ext}_GST80_SUFX?= 80
+${ext}_GST80_PREFIX?= gstreamer-plugins-
+${ext}_GST80_VERSION?= ${GST80_VERSION}${GST80_MINOR_VERSION}
+${ext}_NAME?= ${ext}
+.endfor
.for ext in ${USE_GSTREAMER}
-${ext}_PLIST?=
-${ext}_GST_EXT?= .so
+${ext}_GST_PREFIX?= gstreamer-plugins-
+${ext}_GST_VERSION?= ${GST_VERSION}${GST_MINOR_VERSION}
+${ext}_NAME?= ${ext}
.endfor
+.if defined(USE_GSTREAMER80)
+.for ext in ${USE_GSTREAMER80}
+. if ${_USE_GSTREAMER80_ALL:M${ext}}!= "" && exists(${PORTSDIR}/${${ext}_DEPENDS}${${ext}_GST80_SUFX})
+BUILD_DEPENDS+= ${${ext}_GST80_PREFIX}${${ext}_NAME}${${ext}_GST80_SUFX}>=${${ext}_GST80_VERSION}:${PORTSDIR}/${${ext}_DEPENDS}${${ext}_GST80_SUFX}
+RUN_DEPENDS+= ${${ext}_GST80_PREFIX}${${ext}_NAME}${${ext}_GST80_SUFX}>=${${ext}_GST80_VERSION}:${PORTSDIR}/${${ext}_DEPENDS}${${ext}_GST80_SUFX}
+. else
+BROKEN= "Unknown gstreamer-plugin -- ${ext}"
+. endif
+.endfor
+.endif
+.if defined(USE_GSTREAMER)
.for ext in ${USE_GSTREAMER}
. if ${_USE_GSTREAMER_ALL:M${ext}}!= "" && exists(${PORTSDIR}/${${ext}_DEPENDS})
-. if ${${ext}_PLIST} != ""
-BUILD_DEPENDS+= ${_GST_LIB_BASE}/${${ext}_PLIST}${${ext}_GST_EXT}:${PORTSDIR}/${${ext}_DEPENDS}
-RUN_DEPENDS+= ${_GST_LIB_BASE}/${${ext}_PLIST}${${ext}_GST_EXT}:${PORTSDIR}/${${ext}_DEPENDS}
-. else
-BUILD_DEPENDS+= ${_GST_LIB_BASE}/libgst${ext}.so:${PORTSDIR}/${${ext}_DEPENDS}
-RUN_DEPENDS+= ${_GST_LIB_BASE}/libgst${ext}.so:${PORTSDIR}/${${ext}_DEPENDS}
-. endif
+BUILD_DEPENDS+= ${${ext}_GST_PREFIX}${${ext}_NAME}>=${${ext}_GST_VERSION}:${PORTSDIR}/${${ext}_DEPENDS}
+RUN_DEPENDS+= ${${ext}_GST_PREFIX}${${ext}_NAME}>=${${ext}_GST_VERSION}:${PORTSDIR}/${${ext}_DEPENDS}
. else
-BROKEN= Unknown gstreamer-plugin -- ${ext}
+BROKEN= "Unknown gstreamer-plugin -- ${ext}"
. endif
.endfor
+.endif
# The End
.endif