aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-10-20 20:36:39 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-10-20 20:36:39 +0000
commitf8b75b56199e1ddffa830904c9eed5c55cf4304a (patch)
treef534e97eaee62f9883b7ad6d32b2fd6437427d0e /Mk
parent5c9f71add35d61024beb6537f2645885801bbda6 (diff)
downloadports-f8b75b56199e1ddffa830904c9eed5c55cf4304a.tar.gz
ports-f8b75b56199e1ddffa830904c9eed5c55cf4304a.zip
Notes
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.linux-rpm.mk15
1 files changed, 1 insertions, 14 deletions
diff --git a/Mk/bsd.linux-rpm.mk b/Mk/bsd.linux-rpm.mk
index f4d84a26a5a4..8ee50e5a93ce 100644
--- a/Mk/bsd.linux-rpm.mk
+++ b/Mk/bsd.linux-rpm.mk
@@ -189,10 +189,7 @@ pre-install: linux-rpm-generate-plist
. if !target(linux-rpm-generate-plist)
linux-rpm-generate-plist:
cd ${WRKSRC} && \
- ${FIND} * ! -path "stage/*" ! -type d | ${SORT} > ${PLIST} && \
- ${FIND} * ! -path "stage*" -type d | ${SORT} | ${SED} -e 's|^|@dirrm |' > ${PLIST}.dirs
- @${GREP} '^@dirrm' ${PORTSDIR}/emulators/linux_base-${_LINUX_BASE_SUFFIX}/pkg-plist | ${SED} 's:^@dirrmtry:@dirrm:g' | ${SORT} > ${PLIST}.shared-dirs
- @${COMM} -1 -3 ${PLIST}.shared-dirs ${PLIST}.dirs | ${SORT} -r >> ${PLIST}
+ ${FIND} * ! -path "stage/*" ! -type d | ${SORT} > ${PLIST}
. endif
. endif
@@ -209,14 +206,4 @@ do-install:
cd ${WRKSRC} && ${FIND} * ! -path "stage*" -type d -exec ${MKDIR} "${STAGEDIR}${PREFIX}/{}" \;
cd ${WRKSRC} && ${FIND} * ! -path "stage/*" ! -type d | ${CPIO} -pm -R root:wheel ${STAGEDIR}${PREFIX}
. endif
-
-. if !target(new-plist)
-new-plist: build
- @${RM} -f ${PLIST}.new
- @cd ${WRKSRC} && \
- ${FIND} * ! -path "stage/*" ! -type d | ${SORT} > ${PLIST}.new; \
- ${FIND} -d * ! -path "stage*" -type d | ${SED} -e 's|^|@dirrm |' >> ${PLIST}.new; \
- done
-. endif
-
.endif