aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2009-03-28 20:45:10 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2009-03-28 20:45:10 +0000
commit1a9ef9fa6754e0c0f087f4e7a76e65029a75941c (patch)
treee0596dfc5254e65a6f3de0b5eb6d25f4ad08a7d0 /Mk
parent0804fca67c5eda2be61329599da40c5734b4d634 (diff)
downloadports-1a9ef9fa6754e0c0f087f4e7a76e65029a75941c.tar.gz
ports-1a9ef9fa6754e0c0f087f4e7a76e65029a75941c.zip
Notes
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.perl.mk8
-rw-r--r--Mk/bsd.port.mk4
2 files changed, 8 insertions, 4 deletions
diff --git a/Mk/bsd.perl.mk b/Mk/bsd.perl.mk
index 2897951d8fe6..c0a6ac9df27c 100644
--- a/Mk/bsd.perl.mk
+++ b/Mk/bsd.perl.mk
@@ -26,7 +26,7 @@
# PERL_ARCH - Directory name of architecture dependent libraries
# (value: mach).
# PERL_PORT - Name of the perl port that is installed
-# (value: perl5)
+# (value: perl5.8)
# SITE_PERL - Directory name where site specific perl packages go.
# This value is added to PLIST_SUB.
# USE_PERL5 - If your port needs a specific version of Perl, you
@@ -99,7 +99,9 @@ PERL_LEVEL= 0
PERL_ARCH?= mach
-.if ${PERL_LEVEL} >= 500800
+.if ${PERL_LEVEL} >= 501000
+PERL_PORT?= perl5.10
+.elif ${PERL_LEVEL} >= 500800
PERL_PORT?= perl5.8
.else # ${PERL_LEVEL} < 500800
PERL_PORT?= perl5.6
@@ -149,7 +151,7 @@ masked_PERL_LEVEL= ${PERL_LEVEL}
.if ${want_perl_sign} == "+"
.if ${USE_PERL5_LEVEL} > ${masked_PERL_LEVEL}
-USE_PERL5_REASON?= requires Perl ${want_perl_ver} or later, install lang/perl5.8 and try again
+USE_PERL5_REASON?= requires Perl ${want_perl_ver} or later, install lang/perl5.8 or lang/perl5.10 and try again
IGNORE= ${USE_PERL5_REASON}
.endif # ${USE_PERL5_LEVEL} > ${masked_PERL_LEVEL}
.elif ${want_perl_sign} == ""
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 964d54b600d2..481c5bf5fee9 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1449,7 +1449,9 @@ PERL_LEVEL=0
PERL_ARCH?= mach
-.if ${PERL_LEVEL} >= 500800
+.if ${PERL_LEVEL} >= 501000
+PERL_PORT?= perl5.10
+.elif ${PERL_LEVEL} >= 500800
PERL_PORT?= perl5.8
.else
PERL_PORT?= perl5.6