aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2013-07-25 11:47:11 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2013-07-25 11:47:11 +0000
commita0ccbe7bed7117990389beebe9cb28154cfa470a (patch)
treeebe443b6891930f69bbcd3dd00f2e2795979f32b /Mk
parentcd4fd7cb34f671a0ed72d36b953b48f4c7536d35 (diff)
Notes
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.options.mk28
1 files changed, 23 insertions, 5 deletions
diff --git a/Mk/bsd.options.mk b/Mk/bsd.options.mk
index d6df7c960811..0fb3e40d9128 100644
--- a/Mk/bsd.options.mk
+++ b/Mk/bsd.options.mk
@@ -54,13 +54,14 @@
#
# OPTIONS_SET - List of options to enable for all ports.
# OPTIONS_UNSET - List of options to disable for all ports.
-# ${UNIQUENAME}_SET - List of options to enable for a specific port.
-# ${UNIQUENAME}_UNSET - List of options to disable for a specific port.
+# ${OPTIONS_NAME}_SET - List of options to enable for a specific port.
+# ${OPTIONS_NAME}_UNSET - List of options to disable for a specific port.
#
# OPTIONS_SET_FORCE - List of options to enable for all ports.
# OPTIONS_UNSET_FORCE - List of options to disable for all ports.
-# ${UNIQUENAME}_SET_FORCE - List of options to enable for a specific port.
-# ${UNIQUENAME}_UNSET_FORCE - List of options to disable for a specific port.
+# ${OPTIONS_NAME}_SET_FORCE - List of options to enable for a specific port.
+# ${OPTIONS_NAME}_UNSET_FORCE
+# - List of options to disable for a specific port.
#
# These variables can be used on the command line. They override the effects of
# the make.conf variables above.
@@ -184,13 +185,14 @@ NEW_OPTIONS:= ${NEW_OPTIONS:N${opt}}
. for opt in ${${OPTIONS_NAME}_SET}
. if !empty(COMPLETE_OPTIONS_LIST:M${opt})
PORT_OPTIONS+= ${opt}
+NEW_OPTIONS:= ${NEW_OPTIONS:N${opt}}
. endif
. endfor
-PORT_OPTIONS:= ${PORT_OPTIONS:O:u}
## Unset the options excluded per-port (set by user in make.conf)
. for opt in ${${OPTIONS_NAME}_UNSET}
PORT_OPTIONS:= ${PORT_OPTIONS:N${opt}}
+NEW_OPTIONS:= ${NEW_OPTIONS:N${opt}}
. endfor
# XXX to remove once UNIQUENAME is removed
@@ -251,6 +253,7 @@ PORT_OPTIONS:= ${PORT_OPTIONS:N${opt}}
NEW_OPTIONS:= ${NEW_OPTIONS:N${opt}}
. endfor
+# XXX To remove once UNIQUENAME will be removed
## Set the options specified per-port (set by user in make.conf)
. for opt in ${${UNIQUENAME}_SET_FORCE}
. if !empty(COMPLETE_OPTIONS_LIST:M${opt})
@@ -264,6 +267,21 @@ NEW_OPTIONS:= ${NEW_OPTIONS:N${opt}}
PORT_OPTIONS:= ${PORT_OPTIONS:N${opt}}
NEW_OPTIONS:= ${NEW_OPTIONS:N${opt}}
. endfor
+# XXX To remove once UNIQUENAME will be removed
+
+## Set the options specified per-port (set by user in make.conf)
+. for opt in ${${OPTIONS_NAME}_SET_FORCE}
+. if !empty(COMPLETE_OPTIONS_LIST:M${opt})
+PORT_OPTIONS+= ${opt}
+NEW_OPTIONS:= ${NEW_OPTIONS:N${opt}}
+. endif
+. endfor
+
+## Unset the options excluded per-port (set by user in make.conf)
+. for opt in ${${OPTIONS_NAME}_UNSET_FORCE}
+PORT_OPTIONS:= ${PORT_OPTIONS:N${opt}}
+NEW_OPTIONS:= ${NEW_OPTIONS:N${opt}}
+. endfor
## Cmdline always win over the rest