aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2014-11-27 13:14:24 +0000
committerMathieu Arnold <mat@FreeBSD.org>2014-11-27 13:14:24 +0000
commit4815f5f8ca6c97da71213334033bf09c55376713 (patch)
treedda6b6ee3078a7e9352a89bd4860a1c87333ba0b /Mk
parentffdd303a888deb33dc7dbfea43b0273f5f8384d8 (diff)
downloadports-4815f5f8ca6c97da71213334033bf09c55376713.tar.gz
ports-4815f5f8ca6c97da71213334033bf09c55376713.zip
Notes
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/perl5.mk5
1 files changed, 2 insertions, 3 deletions
diff --git a/Mk/Uses/perl5.mk b/Mk/Uses/perl5.mk
index a756fc68aede..cc8581ba57ef 100644
--- a/Mk/Uses/perl5.mk
+++ b/Mk/Uses/perl5.mk
@@ -271,10 +271,9 @@ PACKLIST_DIR?= ${PREFIX}/${SITE_ARCH_REL}/auto
fix-perl-things:
# Remove STAGEDIR from .packlist and add the file to the plist.
@(if [ -d ${STAGEDIR}${PACKLIST_DIR} ] ; then \
- cd ${STAGEDIR} ; \
- find .${PACKLIST_DIR} -name .packlist | while read f ; do \
+ find ${STAGEDIR}${PACKLIST_DIR} -name .packlist | while read f ; do \
${SED} -i '' 's|^${STAGEDIR}||' "$$f"; \
- ${ECHO} $$f >> ${PLIST}; \
+ ${ECHO} $$f | ${SED} -e 's|^${STAGEDIR}||' >> ${TMPPLIST}; \
done \
fi) || :