aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-05-22 20:56:52 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-05-22 20:56:52 +0000
commit6b8fe3db6b25f7bcd01a20760cb167db1cbb4d2e (patch)
tree89ef1f1c6a4870e8316e08015ab4ee035b7f8ab2 /Mk
parentccac9ebe1b29570efcf236b4f38e6747a4587b1d (diff)
- Split libgsf port to two standalone ports:
* devel/libgsf is the old port minus gsf-gnome bits * devel/libgsf-gnome contains libgsf-gnome-1 library and it's header files This greatly reduces number of dependencies for ports that was using only non-gnome part of this library. - Point USE_GNOME parameter libgsf to GNOME-less port and create new parameter libgsf_gnome for libgsf-gnome port. - Convert all consumers of libgsf-gnome-1 library to depend on libgsf-gnome port (read all as: Gnumeric) PR: ports/63851 (in the spirit of) Submitted by: Sybolt de Boer <sybolt@xs4all.nl> Prodded by: lofi (KDE team) Reviewed by: marcus (GNOME team)
Notes
Notes: svn path=/head/; revision=109734
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.gnome.mk12
1 files changed, 8 insertions, 4 deletions
diff --git a/Mk/bsd.gnome.mk b/Mk/bsd.gnome.mk
index e1063c5df2db..014751adb252 100644
--- a/Mk/bsd.gnome.mk
+++ b/Mk/bsd.gnome.mk
@@ -42,8 +42,8 @@ _USE_GNOME_ALL+=glib20 atk pango gtk20 linc libidl orbit2 \
libgnome libbonoboui libgnomeui atspi libgailgnome \
libgtkhtml gnomedesktop libwnck vte libzvt librsvg2 eel2 \
gnomepanel nautilus2 metacity gal2 gnomecontrolcenter2 libgda2 \
- libgnomedb gtksourceview libgsf pygtk2 pygnome2 gstreamerplugins \
- gtkhtml3 gnomespeech
+ libgnomedb gtksourceview libgsf libgsf_gnome pygtk2 pygnome2 \
+ gstreamerplugins gtkhtml3 gnomespeech
SCROLLKEEPER_DIR= /var/db/scrollkeeper
gnomehack_PRE_PATCH= ${FIND} ${WRKSRC} -name "Makefile.in*" | ${XARGS} ${REINPLACE_CMD} -e \
@@ -381,8 +381,12 @@ pkgconfig_BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
pkgconfig_RUN_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
libgsf_LIB_DEPENDS= gsf-1.10:${PORTSDIR}/devel/libgsf
-libgsf_DETECT= ${LOCALBASE}/libdata/pkgconfig/libgsf-gnome-1.pc
-libgsf_USE_GNOME_IMPL= gnomevfs2 libbonobo
+libgsf_DETECT= ${LOCALBASE}/libdata/pkgconfig/libgsf-1.pc
+libgsf_USE_GNOME_IMPL= glib10 libxml2
+
+libgsf_gnome_LIB_DEPENDS= gsf-gnome-1.10:${PORTSDIR}/devel/libgsf-gnome
+libgsf_gnome_DETECT= ${LOCALBASE}/libdata/pkgconfig/libgsf-gnome-1.pc
+libgsf_gnome_USE_GNOME_IMPL= gnomevfs2 libbonobo
pygtk2_DETECT= ${PYTHON_SITELIBDIR}/gtk-2.0/gtk/__init__.py
pygtk2_BUILD_DEPENDS= ${pygtk2_DETECT}:${PORTSDIR}/x11-toolkits/py-gtk2