aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2014-12-10 15:10:40 +0000
committerMathieu Arnold <mat@FreeBSD.org>2014-12-10 15:10:40 +0000
commit7a6669d8bcf5534e96b1a0b50798f7e3f970ce5b (patch)
treec0852bcc68d26b6fe7055d4d8a197a676534e65c /Mk
parent670d53ad9e3cc3076d384f2465126d7cf76f0e21 (diff)
Notes
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk8
1 files changed, 4 insertions, 4 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index ef1839a5e795..8e92d0436ebe 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1149,7 +1149,7 @@ STRIPBIN= ${STRIP_CMD}
.else
# Look for files named "*.orig" under ${PATCH_WRKSRC} and (re-)generate
-# ${FILESDIR}/patch-* files from them. By popular demand, we currently
+# ${PATCHDIR}/patch-* files from them. By popular demand, we currently
# use '_' (underscore) to replace path separators in patch file names.
#
# If a file name happens to contain character which is also a separator
@@ -1162,7 +1162,7 @@ STRIPBIN= ${STRIP_CMD}
.if !target(makepatch)
PATCH_PATH_SEPARATOR= _
makepatch:
- @${MKDIR} ${FILESDIR}
+ @${MKDIR} ${PATCHDIR}
@(cd ${PATCH_WRKSRC}; \
for f in `${FIND} -s . -type f -name '*.orig'`; do \
ORIG=$${f#./}; \
@@ -1171,14 +1171,14 @@ makepatch:
! for _lps in `${ECHO} _ - + | ${SED} -e \
's|${PATCH_PATH_SEPARATOR}|__|'`; do \
PATCH=`${ECHO} $${NEW} | ${SED} -e "s|/|$${_lps}|g"`; \
- test -f "${FILESDIR}/patch-$${PATCH}" && break; \
+ test -f "${PATCHDIR}/patch-$${PATCH}" && break; \
done || ${ECHO} $${_SEEN} | ${GREP} -q /$${PATCH} && { \
PATCH=`${ECHO} $${NEW} | ${SED} -e \
's|${PATCH_PATH_SEPARATOR}|&&|g' -e \
's|/|${PATCH_PATH_SEPARATOR}|g'`; \
_SEEN=$${_SEEN}/$${PATCH}; \
}; \
- OUT=${FILESDIR}/patch-$${PATCH}; \
+ OUT=${PATCHDIR}/patch-$${PATCH}; \
${ECHO} ${DIFF} -udp $${ORIG} $${NEW} '>' $${OUT}; \
TZ=UTC ${DIFF} -udp $${ORIG} $${NEW} | ${SED} -e \
'/^---/s|\.[0-9]* +0000$$| UTC|' -e \