aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2009-02-04 08:50:50 +0000
committerMartin Matuska <mm@FreeBSD.org>2009-02-04 08:50:50 +0000
commit825c0e60b2a273f0f90b858ff1fb540582a6251d (patch)
tree64f4cbe543b2b0e662100436d545d20927091369 /Mk
parent537e67ef6a1c88e372996658d67d3a8091dec6ea (diff)
downloadports-825c0e60b2a273f0f90b858ff1fb540582a6251d.tar.gz
ports-825c0e60b2a273f0f90b858ff1fb540582a6251d.zip
Notes
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.tcl.mk25
1 files changed, 13 insertions, 12 deletions
diff --git a/Mk/bsd.tcl.mk b/Mk/bsd.tcl.mk
index b2d6f2e6aaac..0da49cbd689a 100644
--- a/Mk/bsd.tcl.mk
+++ b/Mk/bsd.tcl.mk
@@ -7,12 +7,12 @@
.if !defined(_POSTMKINCLUDED) && !defined(Tcl_Pre_Include)
Tcl_Pre_Include= bsd.tcl.mk
-Tcl_Include_MAINTAINER= ports@FreeBSD.org
+Tcl_Include_MAINTAINER= mm@FreeBSD.org
# USE_TCL - Add library dependency on Tcl. If no version is given by the maintainer
# via the port or by the user via defined variable try to find the highest
# stable installed version.
-# Available values: yes 85+ 84+ 83+ 82+ 80+ 85 84 83 82 80
+# Available values: yes 86+ 85+ 84+ 83+ 82+ 80+ 85 84 83 82 80
# NOTE: - default value 84 is used in case of USE_TCL=yes
#
# USE_TCL_BUILD - Add buildtime dependency on Tcl (tclsh).
@@ -51,7 +51,7 @@ Tcl_Include_MAINTAINER= ports@FreeBSD.org
# USE_TK - Add library dependency on Tk. If no version is given by the maintainer
# via the port or by the user via defined variable try to find the highest
# stable installed version.
-# Avaliable values: yes 85+ 84+ 83+ 82+ 80+ 85 84 83 82 80
+# Avaliable values: yes 86+ 85+ 84+ 83+ 82+ 80+ 85 84 83 82 80
# NOTE: - overrides USE_TCL
# - default value 84 is used in case of USE_TK=yes
#
@@ -191,17 +191,18 @@ INVALID_TCL_VER:= ${INVALID_TK_VER}
. if defined(USE_TCL)
_TCL_DEFAULT_VERSION= 84
-_TCL_VERSIONS= 85 84 83 82 80
-_TCL_THREADS_VERSIONS= 85 84
-_TCL_RANGE_VERSIONS= 85+ 84+ 83+ 82+ 80+
-_TCL_THREADS_RANGE_VERSIONS= 85+ 84+
+_TCL_VERSIONS= 86 85 84 83 82 80
+_TCL_THREADS_VERSIONS= 86 85 84
+_TCL_RANGE_VERSIONS= 86+ 85+ 84+ 83+ 82+ 80+
+_TCL_THREADS_RANGE_VERSIONS= 86+ 85+ 84+
# For specifying [85, 84, ..]+
-_TCL_80P= 80 82 83 84 85
-_TCL_82P= 82 83 84 85
-_TCL_83P= 83 84 85
-_TCL_84P= 84 85
-_TCL_85P= 85
+_TCL_80P= 80 82 83 84 85 86
+_TCL_82P= 82 83 84 85 86
+_TCL_83P= 83 84 85 86
+_TCL_84P= 84 85 86
+_TCL_85P= 85 86
+_TCL_86P= 86
# Set the default Tcl version and check if USE_TCL=yes was given
. if ${USE_TCL} == "yes"