aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2013-08-31 13:56:08 +0000
committerBryan Drewery <bdrewery@FreeBSD.org>2013-08-31 13:56:08 +0000
commit954b6504628b47d268ae6e4327861560767b6884 (patch)
tree51eb0b479540ae133f43750381f2279e19e9ab3b /Mk
parent6bad5fa85fc0cedf263e67827e7724931ccc92e5 (diff)
downloadports-954b6504628b47d268ae6e4327861560767b6884.tar.gz
ports-954b6504628b47d268ae6e4327861560767b6884.zip
Notes
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk13
1 files changed, 10 insertions, 3 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index aa3a17a94ddd..1b772b6a1118 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1084,8 +1084,11 @@ FreeBSD_MAINTAINER= portmgr@FreeBSD.org
# a different checksum and you intend to verify if
# the port still works with it.
# USE_PACKAGE_DEPENDS
-# - Install dependencies from existing packages instead
-# of building the port from scratch.
+# - Try to install dependencies from existing packages instead
+# of building the port from scratch. Fallback on source
+# if an existing package is not present.
+# USE_PACKAGE_DEPENDS_ONLY
+# - Like USE_PACKAGE_DEPENDS, but do not fallback on source.
# INSTALL_AS_USER
# - Define this to install as the current user, intended
# for systems where you have no root access.
@@ -4906,7 +4909,7 @@ _DEPEND_ALWAYS= 0
.endif
_INSTALL_DEPENDS= \
- if [ X${USE_PACKAGE_DEPENDS} != "X" ]; then \
+ if [ -n "${USE_PACKAGE_DEPENDS}" -o -n "${USE_PACKAGE_DEPENDS_ONLY}" ]; then \
subpkgfile=`(cd $$dir; ${MAKE} $$depends_args -V PKGFILE)`; \
subpkgname=$${subpkgfile%-*} ; \
subpkgname=$${subpkgname\#\#*/} ; \
@@ -4920,6 +4923,10 @@ _INSTALL_DEPENDS= \
else \
${PKG_ADD} $${subpkgfile}; \
fi; \
+ elif [ -n "${USE_PACKAGE_DEPENDS_ONLY}" ]; then \
+ ${ECHO_MSG} "===> ${PKGNAME} depends on package: $${subpkgfile} - not found"; \
+ ${ECHO_MSG} "===> USE_PACKAGE_DEPENDS_ONLY set - will not build from source"; \
+ exit 1; \
else \
(cd $$dir; ${MAKE} -DINSTALLS_DEPENDS $$target $$depends_args) ; \
fi; \