aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2017-12-04 11:07:10 +0000
committerMathieu Arnold <mat@FreeBSD.org>2017-12-04 11:07:10 +0000
commit9b3f71316a74f837e5184c8e3e4be77bd94aee97 (patch)
tree05987ed6ec133c9a2dd62d1ee2d52c5b2aab1d43 /Mk
parentc891fd5d24a31ab6ce54af748fdd73ce3eae60aa (diff)
downloadports-9b3f71316a74f837e5184c8e3e4be77bd94aee97.tar.gz
ports-9b3f71316a74f837e5184c8e3e4be77bd94aee97.zip
Notes
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/python.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/Mk/Uses/python.mk b/Mk/Uses/python.mk
index c84f1474c2e8..1e1fd8ffbbdd 100644
--- a/Mk/Uses/python.mk
+++ b/Mk/Uses/python.mk
@@ -341,9 +341,11 @@ PYTHON3_DEFAULT_VERSION?= python${PYTHON3_DEFAULT}
.if ${_PYTHON_ARGS} == "2"
_PYTHON_ARGS= ${PYTHON2_DEFAULT_VERSION:S/^python//}
_WANTS_META_PORT= 2
+DEV_WARNING+= "USES=python:2 is deprecated, use USES=python:2.7"
.elif ${_PYTHON_ARGS} == "3"
_PYTHON_ARGS= ${PYTHON3_DEFAULT_VERSION:S/^python//}
_WANTS_META_PORT= 3
+DEV_WARNING+= "USES=python:3 is deprecated, use USES=python:3.4+ or an appropriate version range"
.endif # ${_PYTHON_ARGS} == "2"
.if defined(PYTHON_VERSION)