aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2021-09-06 17:16:38 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2021-09-06 19:28:28 +0000
commitb1670e2c3d42a2aeacff843ef0ccea21c0929d03 (patch)
treeec01615cd0e0f43e4defe8feaf95d24a9983444e /Mk
parentb7fe3caf7f6c269458d86cdf77cc59568b6d5041 (diff)
downloadports-b1670e2c3d42a2aeacff843ef0ccea21c0929d03.tar.gz
ports-b1670e2c3d42a2aeacff843ef0ccea21c0929d03.zip
lang/rust*: Mk/Uses/cargo.mk: Move TMPDIR to WRKDIR
rustc stashes intermediary files in TMPDIR (default /tmp) which might cause issues for users that for some reason space limit their /tmp. WRKDIR should have plenty of space. Other ports that use rustc might be affected too, but set it only in USES=cargo and lang/rust* ports for now. PR: 258126 With hat: rust
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/cargo.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/Mk/Uses/cargo.mk b/Mk/Uses/cargo.mk
index ad8c8d8d20ce..a0a88701e62e 100644
--- a/Mk/Uses/cargo.mk
+++ b/Mk/Uses/cargo.mk
@@ -125,6 +125,14 @@ CARGO_TEST?= yes
CARGO_USE_GITHUB?= no
CARGO_USE_GITLAB?= no
+# rustc stashes intermediary files in TMPDIR (default /tmp) which
+# might cause issues for users that for some reason space limit
+# their /tmp. WRKDIR should have plenty of space.
+# Allow users and ports to still overwrite it.
+.if ${TMPDIR:U/tmp} == /tmp
+TMPDIR= ${WRKDIR}
+.endif
+
# Manage crate features.
.if !empty(CARGO_FEATURES:M--no-default-features)
CARGO_BUILD_ARGS+= --no-default-features